You must be logged in to post messages.
Please login or register

AoW:SM Tech Help & Bug Reporting
Moderated by Swolte, Ziggurat Mason

Hop to:    
loginhomeregisterhelprules
Bottom
Topic Subject: Random crashes and Video problems
« Previous Page  1 2 3  Next Page »
posted 07-28-03 04:20 AM EDT (US)   
Just a reminder that lockups, random crashes, and corrupted graphics are often caused by bugs in video drivers. When encountering problems in aowSM (or any game), players should check for newer drivers, DirectX versions, etc.

In the case of Nvidia cards, some users have reported better results with the older 41.09 drivers than with newer ones, so users experiencing problems in aowSM may wish to try those drivers as well.

Using aowSetup to disable Direct3D, DirectSound, and/or Resolution Switching may also correct problems, and changing your desktop to 16-bit color has worked for a few people as well.

Replies:
posted 10-13-09 08:02 AM EDT (US)     61 / 73  
If you see my response wasn't for you
I then answered your questions since your post followed mine.
So you were answering my questions, but the response wasn't for me?

Thanks for the lecture, but I assume that all this "holier than thou" stuff is to cover up your embarrassment over the fact that you completely misunderstood
When you start the game, what version number does it show in the bottom right corner of the first screen?
If I wanted to continue your "holier than thou" theme I would probably point out that my answers may well prove useful for other people that come into this thread at a later date with a similar problem - but I can't be bothered!

Incidentally I am a very experienced forum member, and was an angel here for about a year, so I think I have a fairly good idea of how to post... thanks for the advice, anyway

"Shooting down a plane of civilians isn't careless, it's politcal opportunism." - Stormraider
posted 10-13-09 10:02 AM EDT (US)     62 / 73  
So you were answering my questions, but the response wasn't for me?

Thanks for the lecture, but I assume that all this "holier than thou" stuff is to cover up your embarrassment over the fact that you completely misunderstood .
My second post from this year was answering your questions for you. My first post from this year was not for you.

It's not a "holier than thou"... the fact is you posted brief questions directly after my post without quoting anyone. It would be like me posting in the Today at GS thread and asking the question, "What patch version do you use?" then expecting everyone who posted to know who I was asking. LOL

Goofy Rabbit. :P

Today at GS: http://aow.heavengames.com/cgi-bin/forums/display.cgi?action=ct&f=30,5279,,60
If I wanted to continue your "holier than thou" theme I would probably point out that my answers may well prove useful for other people that come into this thread at a later date with a similar problem - but I can't be bothered!

Incidentally I am a very experienced forum member, and was an angel here for about a year, so I think I have a fairly good idea of how to post... thanks for the advice, anyway
Again it's not "holier than thou"... it's simply advice for avoiding forum confusion. I provided an example earlier, but I think you're embarrassed for your mistake and too stubborn to admit it. Again you're original question could be for any individual who posted, but don't expect others in the community to read your mind. Quotes are your friend.

There can be only one.
Highlander
posted 10-13-09 10:40 AM EDT (US)     63 / 73  
I'm not sure you really do know how to post Roger since you contribute so many 'holier than thou' corrections of people's grammar, condescending answers to simple questions, or unnecessary reproachments over posts you deem to be in the wrong section.
posted 10-16-09 05:27 AM EDT (US)     64 / 73  
Since I have my 'new' PC (itīs an AMD Dual core 2000 MHZ, 2GM RAM, ATI Radeon 1600 series....) AOW is crashing sometimes, totally randomly and unpredictably but I think I can say it happens exclusively in combat mode.

I found this here in this thread which might be the solution hopefully:
Since this is in a sticky post, I will add the "fix" for the System Time Error given in the link above:
Quoted from griplinken:

...Fixed! Apparently I needed to set the AoWSM.exe executable to use only 1 CPU.

On Windows XP:

1) Start up AoW: SM
2) Hit Ctrl-Alt-Delete and pull up the Task Manager
3) Right-click the AoWSM.exe executable and click "Set Affinity".
4) Uncheck any and all CPUs until the process can only use 1 CPU
5) Done!
But since I had AOWSM run on another Dual core since a couple of month ago for roughly 11/2 years without any problems, thereīs a fair chance that the usage of two CPUīs is NOT the rootcause...

The crashes are always a follows: In the blink of an eye the game is simply vanished - it takes 1/1000 second from full screen gameplay to gone without any trace... all other applications continue to work perfectly without problem and I also can start AOW again without any problem.
So no brutal crash after which nothing works anymore (which I also have had in the past...)

If anybody has any idea what I could do/check Iīd appreciate yuor help.
I have all most actual drivers on the system as well as the latest DirectX.

Author of the following maps for AOWSM:
Version 1.4: DEMONWARS II (Transcendence & Immortalis)
Version 1.3: (also playable in 1.4) Gates to another World 1.4
><-><-><- Planning replaces coincidence by error. -><-><-><-
posted 10-16-09 05:54 AM EDT (US)     65 / 73  
Maybe I can help, and may our game become restartless

I had this kind of crashes a couple of times when I was playing AOW SM in singleplay leaving my children's favorite website in background in a browser, playing music, with speakers off (I always play AOW SM with speakers off). I guess trying to access same sound FX resourses could be a problem.

Try turning the sound/music off, lowering graphics resolution / turning some visual effects off too - sometimes it helps with the older games...

Spell check failed - not enough mana
posted 10-16-09 07:03 AM EDT (US)     66 / 73  
hmm, indeed I have sound also turned off as standard setting... maybe I should disable sound in the setup as well, thatīs a good idea.
Iīll play with all kind of settigns during the weekend and hopefully find out, what is responsible for the crashes.
I will definately quit Firefox (or any other browser) before I start AOW, maybe this causes the trouble.

What about the dual core??
I assume, most people have double or even quad core PCīs today!? does anbody have problems with AOW with such a modern PC?
Are you also manually changing to use-only-one-core in the Task manager?? I can hardly imagine...

Author of the following maps for AOWSM:
Version 1.4: DEMONWARS II (Transcendence & Immortalis)
Version 1.3: (also playable in 1.4) Gates to another World 1.4
><-><-><- Planning replaces coincidence by error. -><-><-><-
posted 10-16-09 11:39 AM EDT (US)     67 / 73  
Mine is dual, and I never bothered with that. Maybe I should, it probably won't hurt.

Spell check failed - not enough mana
posted 10-16-09 12:33 PM EDT (US)     68 / 73  
I unselectet direct sound, sound fx and a video option and changed the settings of the running AOW exe to use-one-CPU-only.
Then I ran a game while Internet was running in parallel, switched ten times from one to the other, made some battles, switched again and it didnīt crash.
I hope with these tricks it remains stable now but itīs probably to early the cheer in victory...

Author of the following maps for AOWSM:
Version 1.4: DEMONWARS II (Transcendence & Immortalis)
Version 1.3: (also playable in 1.4) Gates to another World 1.4
><-><-><- Planning replaces coincidence by error. -><-><-><-
posted 01-01-10 09:59 AM EDT (US)     69 / 73  
Operating System: Microsoft Windows XP (5.12600)
DirectX Version: 9.0 (4.09.00.0904)
Desktop Resolution: 1024x768x16
Physical Memory: 337 / 1022 MB
Virtual Memory: 1842 / 2047 MB
Winsock 2 Detected: YES

AoWSM Version: 1.00
Resources ID: 0
Display Resolution: 1024x768x16
Display Mode: Full Screen
Pixel Format: 5-6-5
3D Renderer: Hardware
Display Driver: NVIDIA GeForce 7600 GT (nv4_disp.dll)
Driver Version: 0.0.0.0 (4318 / 736)

Detail Level: High
Cursor Mode: Software
Sound: On
Music: On
DirectSound: On

Map: Julia1.a2c
Day: 36
Play Mode: Simultaneous
Connection Type: Local
Players: 3
Human Players: 1
Seated Player: 1
Current Player: 1

Combat: Auto Replay
Location: 43,57,0
Players: 2
Current Player: -1

Application opened at: 3:27:23 PM
System Time Error - Restart AoW2
Application closed at: 3:40:21 PM (1 errors)


I have read a load on this topic, and some things are fixed now, but it still keeps crashing in game. First the game crashed when i tried to start a scenario or a campaign (i havnt gotten any further than julia 2 with a lot of patience and luck) and then i read here i had to update my driver, i did, and now it doesnt do that, but it still crashes ingame.

It says: restart aow2, but i dont have aow 2 on my computer anymore, and deleted any file related to it.

hope you guys can help.
posted 01-01-10 07:35 PM EDT (US)     70 / 73  
Do like they said in the 1st post.
Try one thing after another to locate possible cause:
Disable sound effect
Disable Direct3D

Also install the v1.3 official patch (or unofficial v1.4)
posted 01-04-10 07:58 AM EDT (US)     71 / 73  
This has nothing to do with Aow2: Wizard's Throne. You should try patch your game first. I noticed that your game version is 1.0. You should update it to Upatch 1.4. If the problem still persists after that, you should try tweaking the video settings in Aow:SM setup (Start Menu>>> Aow:SM>>> Aow:SM Setup).

Try open some custom scenarios too. The problem may lie within the scenario or the game save itself. In that case, you will probably have to replay. A bad game save (due to disk write failure, crashes during save...) could end your game prematurely.


Tired of manually receiving/sending your PBEM turns everyday ? Try out Dave's PBEM Wrapper!
posted 05-17-13 11:41 AM EDT (US)     72 / 73  
The game crashes sometimes before I even move, when just switching between messages, groups and areas. My suspicions are on video problems and/or disk access of unloaded sprites/tiles.
It only happens in my Strange Lands mod games

Spell check failed - not enough mana
posted 05-18-17 12:00 PM EDT (US)     73 / 73  
Hi. If there is anyone to hear...
I have problem with game (Age of Wonders Shadow Magic - with unofficial patch installed) crashing on game loading. Game log says it's "error during map draw." It's crash less than a second after finish loading.
I tried driver update and all compatibility modes, it always happens again.
I tried to do that Task manager thing but can't because game crashes when I open task manager.
It's Windows 10. Funny thing is game worked (somehow ,windowed mode, cause in full screen there's some blurry thing with map textures)since today and than for no reason it just stopped and those crashes started. Editor works fine.
« Previous Page  1 2 3  Next Page »
Age of Wonders 2 Heaven » Forums » AoW:SM Tech Help & Bug Reporting » Random crashes and Video problems
Top
You must be logged in to post messages.
Please login or register
Hop to:    
Age of Wonders 2 Heaven | HeavenGames