You must be logged in to post messages.
Please login or register

AoW2 Technical Help
Moderated by Swolte, Ziggurat Mason

Hop to:    
Topic Subject: Scenario Edtior Bugs & Anomalies
« Previous Page  1 2  Next Page »
posted 06-13-02 10:28 AM EDT (US)   
Line 'em up here. I'll start.

  • When creating a new map, "Desert" is listed twice in the drop-down menu for "Fill Terrain Type."
  • Replies:
    posted 07-20-02 01:11 AM EDT (US)     31 / 56  
    I also gave boats to everyone and haven't seen them move one once, ever. I gave them the boats because I have everyone separated by big oceans. But it comes to a point where they just sit around playing cards or rolling dice because they're not doing anything else. Now, if I set exploration off, then they start to get more excited, because they seem to be able to see there is something to go out and do.

    Another problem I've developed is the scenario I have been playing won't reload. It was working fine. All of a sudden, when I want to reload a game it will just lock up. I can load other games just fine, and the scenario loads fine when beginning the scenario. I've tried it on two different computers with the same result.

    posted 07-22-02 02:31 PM EDT (US)     32 / 56  
    sometimes (i can't tell what to do to get that error) my screen is totally messed up. e.g. gray tile graphics just over every button and menu points. the screen flickers etc. once i made a xl map with icy underground. but in the mini-map window it was still green. after i moved to the middle of the screen the minimap updated to white. looks like another memory handling problem to me.
    posted 07-23-02 12:31 PM EDT (US)     33 / 56  
    I want to customise an independent hero with Level 30. Just like one could with AoW1! But the editor only allows a lvl 20 cap?! I don't want to give them all-powerful items as I do not want players to walk around with items designed only to buff-up the hero!

    Get the unofficial Patch v1.4. here!
    My best AoW-Sm map: Drums of Death (This is the multiplayer version; for single player, or AI use different version)
    Other proud AoW-sm maps: The Key of Kharzul, The Fight for Light, Waikiti Island, Goldrush Mountains
    My proud AoW2 maps:The River Arne
    Coordinator of the v1.4 and v1.5 patchteams, Seraph of AoWHeaven, PBEM Singles Champion 2008
    posted 07-25-02 08:44 PM EDT (US)     34 / 56  
    I was also having trouble with the editor with my old comp: same thing as others: FPS flickers very quickly, then at random times (usually when trying to change the information on the "main" screen: number of players on a map, for example) the editor interface mucks up/freezes etc. The game ran fine, except for the slowdown that many seem to get after an hour or so.

    Specs were:

    Win 98 second edition
    SiS 6 vid card (argh!)
    Direct X 8.1
    128MB RAM
    Pentium II 400Mhz
    Optima monitor

    I updated my computer a couple of days ago, (which among other things fixed my IE problems and I can now run NWN properly yoo-hoo!) so to all intents and purposes I have a brand new comp. The game runs much better, but the editor is acting no differently... it is still very, very unstable. Hitting F9 will NOT turn off the FPS either.

    Specs now are:

    Celeron 1.3 Gighz processor
    256 MB RAM
    GeForce2 vid driver (fully updated).
    Direct X 8.1
    Win 98 2

    I never did like anyone who didn't have a temper. If you don't have a temper, you don't have any passion.
    posted 07-25-02 09:07 PM EDT (US)     35 / 56  
    SP doesn't work on heroes if you select abilities. You can go into the negative zone as much as you want. Only stats are affected by SP. This defeats the purpose of a limit of SP if you can violate it.
    posted 07-27-02 04:51 PM EDT (US)     36 / 56  
    I noticed that Resurgence in Da Bomb and Stained Tunic didn't work. The patch fixed the problem. Thanks for that!
    There's also a problem with Crown of Command: Leadership doesn't work. It says "Leadership I" in the hero's ability list, but it does nothing. I have tested. I don't know if others are having the same problem. Thanks for the great game!
    posted 07-27-02 07:53 PM EDT (US)     37 / 56  
    Mabye someone can explain this.

    I build up a pool of water, then made a hill on one side that was max height, then I tried to line the pool with cave walls (I was messing around) just went crazy and started randomly changing the land height whenever I put another tile down.

    posted 07-28-02 01:47 AM EDT (US)     38 / 56  
    Above ground you can't change the elevation of a water tile (which I believe is how it's supposed to be) while you can change the elevation of a water tile Underground.

    There's a typo in an error. I tried to put a Magic Catalyst in water (which is impossible) and it put the message "Excetion during MapFrame.OnMouseDown" in the status bar. That first word should be "Exception"

    You can place stalactite/stalagmite formations on the surface for some reason...

    When you place a cave wall on the surface, it creates a max height hill to put it on.

    It's impossible to put units on top of cave walls, but you can put cave walls down on top of units, which puts the units on top of the wall. After doing this, it doesn't allow you to remove the cave wall from under the units. This also happens with various other scenery, such as trees, except that it does allow you to remove the wall afterwards.

    It allows you to put stactite/stalagmite formations on top of cave walls.

    posted 08-06-02 02:24 AM EDT (US)     39 / 56  
    Post 1.1 Patch Problems I'm noticing:

    - Mana Reached Flag condition for events does not work (haven't tried Gold Reached Condition).

    - In the Map Settings, Under Players Tab, if you select Type: Human for the wizard, and check the Fixed box next to it, it forces the wizard to be CPU player. "Fixed" should say "CPU only"

    posted 08-19-02 12:40 PM EDT (US)     40 / 56  
    Minor (but useful) enhancements, not bugs:

    - Show the ID of the highlighted structure on the status bar of the Scenario Editor (Useful when editing Events, especially useful when trying to find the ID of a House of Healing)

    - Don't automatically re-scroll the Event list when selecting an event on a very long event list. Right now, if you have an event list that is longer than the number of events that can fit on the event window, and you select an event, the event list will scroll the highlighted event to the bottom of the window. A pain in the but when you have a large event list. If this is confusing, just email me at and I'll send you some screen shots of it in action)

    posted 08-21-02 07:46 AM EDT (US)     41 / 56  
    posted 08-25-02 09:48 PM EDT (US)     42 / 56  
    Observed: cutting and pasting of objects (particular cities) has a tendency to cause Editor not-responsiveness.

    "Where there is imagination, the possibilities are endless."
    Age Of Wonders 2 Heaven | AOW2H Scenario Designers' Hall
    posted 08-26-02 05:30 AM EDT (US)     43 / 56  
    You can spawn units with a.i. , you can't set when they are just placed on the map.
    posted 09-01-02 03:45 PM EDT (US)     44 / 56  
    Capturing a rift node for the first time (ie. when the rift node is bound to your sphere) does not cause an event with a trigger:structure flagged event that is set to the rift node's ID to "trigger".

    [This message has been edited by josborne (edited 09-01-2002 @ 03:46 PM).]

    posted 09-19-02 08:32 AM EDT (US)     45 / 56  
    Is the spell " Solar Flare" missing from the starting speels for the wizards in the Scenario Editor ?
    posted 10-02-02 03:02 PM EDT (US)     46 / 56  
    Here are some answers to comments in this post:

    Angel Draco
    Short-cut keys don't work, like CTRL+X, CTRL+V, ect.

    I'm not sure what context you are referring to here. On the map, cut-n-paste does work (though there may be a bug associated with it...see Bluecollarheaven's post and my comments below.) Cut-n-paste also works in the events setup, but only for have to click on the event then you can cut/copy it and paste it. Cut-n-Paste does not work on the conditions.

    Have we lost the ability to customize the defenders of haunted crypts and the like? I used to enjoy adding mummies to crypts and ancient ruins because it was the only time one would see those units in the game (in AoW1).
    What if I want to create a camp of Orcs? Or a camp of Dark Elves? I can't specifiy that anymore.

    YOu can add custom defenders by one of two methods:

    1. Place units on the crypt, set to independent with "Guard" AI. The units will not appear when you play the map, but will be the denizens of the site.

    2. Create a "Spawn Unit" event, for independent units to spawn on the crypt's hexigon. The units will become denizens of the site. It does not seem to matter what AI you assign the units.

    In addition, you can still use the denizen setting of the crypt along with the added denizens.

    Raging Joel


    It's possible to place cavern tiles above ground, but it's not possible to place dirt tiles above ground... :/

    You can place dirt tiles/paint on the surface by using one of the tiles. I like to use mushrooms, then use the X-mushroom tile to remove the mushrooms, leaving plain dirt tiles.

    A Quest question:
    When making a quest, it asks for days, like earliest and last days, which I assume is the start and end points, but quests always seem to fail if not completed in ten days. Is this a bug?

    You can disable the "10 days" limit by setting autoreward to false.

    Observed: cutting and pasting of objects (particular cities) has a tendency to cause Editor not-responsiveness.

    I have not noticed this, but I do think I get a mousedown error when I cut-n-paste objects (I'll check it out and get some better details on this). I do get non-responsiveness whenever I try to run another program with the editor (such as AoW2 or MS Word). The programs do not crash, but they do "freeze" for several seconds every so often. Also, if Windows XP swiches to screen saver while the editor or game (alone) is running, it can take the computer several minutes to respond and show the login screen.

    You can spawn units with a.i. , you can't set when they are just placed on the map.

    You can set the AI for a party placed on the map by right-clicking the units (Army), clicking "edit" and then setting the AI in the dialogue window.

    [This message has been edited by TalonThorn (edited 10-02-2002 @ 03:10 PM).]

    posted 12-17-02 02:23 PM EDT (US)     47 / 56  
    Editor Crashes after a minute or so, but game runs fine.

    Windows 98
    Pentium III 450mhz
    384 Mb RAM
    Diamond Stealth III 32Mb video

    posted 12-26-02 10:27 AM EDT (US)     48 / 56  
    I got solution to my problem from Josh.
    Just turned 3d off when using editor, and worked.
    Its just too slow, but can use it now.
    posted 01-06-03 11:29 AM EDT (US)     49 / 56  
    I have read some of the Problems you have with the editor
    the 5 box wide thing cant be fixed, but if you click and hold on the picture of an item and drag the mouse left or right you can scrol (excuse this, i know it is spelled wrong) And if you want to ad specific items/guards to campsites,crypts etc. just click the item/unit tab and place some units on the "explorable place"
    (Remember to set defenders to "none")
    and now i have a problem
    if i edit something in map settings and then press "OK"
    or "cancel", it all screws up
    please help me

    posted 03-07-03 05:03 PM EDT (US)     50 / 56  
    I have editing problem similar to 'checat'. Map editing is fine, until I exit the page dealing with Wizard background and detail. I don't know why it would give me little tiles and windows all over the screen. When editing terrain features on map it works OK, so I do this first before entering Wizard info. After the 'tile mosaic' appears I can still make out the "save as" option under the pull down tabs, and then select exit. When re-entering editor and loading my scenario again it appears fine again.

    Suggestion: Check if these many editor bugs appear more or appear less depending on Operating System. I am using Windows 98 (1st Edition) and have found it to be more stable than 2nd Ed. or Windows ME.

    posted 04-17-03 04:42 PM EDT (US)     51 / 56  
    How does the automatical naming of cities work? When I place a city in the editor and do not give it a name, it is called "Namenlos" (german word for "Nameless") in the game. But it seems that it works on other maps. Can it be, that only cities called "Nameless" are named?
    posted 04-17-03 06:47 PM EDT (US)     52 / 56  
    Are the cities called "Namenlos" in game? In the editor they will always appear as "Noname" or "Namenlos", but the game automatically generates names when the map is loaded. Try loading your map in the game, even if it isn't finished it will load (put a couple of wizards on it to give you time to check things out). If the cities are still Namenlos, then there is a problem, but I bet they will all have new names.

    Author of the following maps for AOWSM:

    Version 1.4 - Race To Death: Rise Of Evil
    Version 1.3 (also playable in 1.4) - Race to Death S&M - Walker's Crusade ====== This Land Is My Land ====== War In The Valley

    Proud member of the Upatch Team

    posted 04-18-03 11:13 AM EDT (US)     53 / 56  
    This belongs in the "Anomaly" category. It seems awful strange that Palm Trees are in the Desert library, instead of the Beach library. Would seem to make more sense in reverse, or perhaps they could be common to both?

    Author of the following maps for AOWSM:

    Version 1.4 - Race To Death: Rise Of Evil
    Version 1.3 (also playable in 1.4) - Race to Death S&M - Walker's Crusade ====== This Land Is My Land ====== War In The Valley

    Proud member of the Upatch Team

    posted 11-07-05 04:57 PM EDT (US)     54 / 56  

    Quoted from King David:

    It seems awful strange that Palm Trees are in the Desert library, instead of the Beach library.

    Why "instead" ? Palms don't grows in the deserts ?

    Well, let's name things by their own names. There's "Tree" resource object with following properties:
    Object Type=Oak Trees,
    Terrain Type=Desert,
    and 4 of such resources are placed in "Desert" group (with Density 0 ... 6).
    But where's anomaly here ? Only little imperfection of resources (sadly, not single ).
    After all, nothing can prevent any Mod-maker from duplicating them to Beach group with Terrain Type changed to Beach, right ?
    BTW, good idea. I'll post this suggestion for 1.4 unofficial patch (or it's already done ? it looks too simple).
    (edit): other stuff removed to AoWSM Tech forum - sorry, failed to discern it in forums droplist.

    And even I make no pretence Of having more than common sence - R.W.Wood
    The secret half a country keeps, the whisper in the lane... - R.Kipling
    [UPatch 1.4 Team] * STLpack

    [This message has been edited by Turbo Beholder (edited 11-08-2005 @ 11:28 PM).]

    posted 01-14-08 05:44 PM EDT (US)     55 / 56  
    i have a very weird problem, i have no problems with the game running but when i download maps from the web site my game . doesnt know what they are unless the file says ahm at the end almost all of the map files have hsm at the end. i looked in the mod downloads but i didnt see anything about a program that would let me use those map files. yes i do know this is the tech forum not the software furom but i dont know where to post my problem, because i dont see it listed. if your are going to erase this post because its in the wrong spot could you please send me a anwser to this problem or the names of maps with ahm at the end to my email at
    posted 01-15-08 11:27 AM EDT (US)     56 / 56  
    Hi iamgenestarwind, it seems u might be downloading aow1 maps. I too were downloading those maps and was wondering why it wasnt working. Get ur maps here
    we might get our posts moved
    « Previous Page  1 2  Next Page »
    Age of Wonders 2 Heaven » Forums » AoW2 Technical Help » Scenario Edtior Bugs & Anomalies
    You must be logged in to post messages.
    Please login or register
    Hop to:    
    Age of Wonders 2 Heaven | HeavenGames