You must be logged in to post messages.
Please login or register

AoW2 Technical Help
Moderated by Swolte, Ziggurat Mason

Hop to:    
Topic Subject: Scenario Edtior Bugs & Anomalies
« Previous Page  1 2  Next Page »
posted 06-13-02 10:28 AM EDT (US)   
Line 'em up here. I'll start.

  • When creating a new map, "Desert" is listed twice in the drop-down menu for "Fill Terrain Type."
  • Replies:
    posted 06-13-02 04:45 PM EDT (US)     1 / 56  
    Another one:

  • None of the mana nodes are identified as their specific spheres. The earth nodes are labled "node," the Air Node is labeled "node," the random node is labeled "node," ect.

  • posted 06-14-02 11:52 AM EDT (US)     2 / 56  
    1) The tooltips for a lot of the different art assets are wrong.

    "fragmentary rt"?

    2) Using the location point (whatever that is, still can't figure it out. See my question thread on the scenario board if you want to answer)Placing it and changing the index causes a memory error. Either late tonight or late tomorrow night I will post the memory address.

    3) AutoScroll doesnt seem to work

    4)Adding a wizard and then deleting him in quick succession causes graphical glitches.

    posted 06-14-02 12:33 PM EDT (US)     3 / 56  
  • Short-cut keys don't work, like CTRL+X, CTRL+V, ect.

  • Right-clicking on a army brings up the Army Properties window, but clicking the "ADD" button does nothing. It's impossible to edit a unit stack from within the Properties window.

  • Many of the item libraries are 5 boxes wide, but the pop-up window displaying them is only 4 boxes wide, with the tiniest sliver of the 5th boxes showing. Clicking on that sliver of a box will display the other items there. However, there is no left-right scroll, so you can't go back to see the left-hand column! You have to close the window and open it again.

    This happens with choosing custom magic items hero portraits.

    Why make the libraries 5 boxes wide when it could just be a longer vertical scroll? There are a lot of empty boxes down there.

    [This message has been edited by Angel Draco (edited 06-14-2002 @ 12:58 PM).]

  • posted 06-14-02 01:14 PM EDT (US)     4 / 56  
    Frustrating bug in the Hero properties when assigning magic items. I'll highlight the Helmet slot, select the helmet design I want, click ADD and it will appear in the Helmet slot.

    No problems so far.

    Now, I select the sword slot, choose a magic sword I want, hit the ADD button, but now it's all screwed up. The helmet I previously selected appears in the RING slot, and the sword icon I just added appears in the ARMOR slot.

    Deleteing the icons from their wrong slots and reassigning yeilds the same results. It's basically impossible to assign the heroes (either pre-existing or user-made) any magic items.

    What am I doing wrong? And if I'm not doing anything wrong, this editor sure is buggy. A good editor is what exetended the life of AoW for so long, I hope this one is patched.

    posted 06-14-02 01:46 PM EDT (US)     5 / 56  
  • What happened to the small bag representing the item you had selected following your cursor around until you clicked on the map to indicate you had deposited it? Now, all you do is click on the magic item to select it, and click on the bag. But there is no visual cue to indicate the item was added. I tried this several times thinking there was something wrong until I released I had added 6 rings to the bag.

  • Have we lost the ability to customize the defenders of haunted crypts and the like? I used to enjoy adding mummies to crypts and ancient ruins because it was the only time one would see those units in the game (in AoW1).

    What if I want to create a camp of Orcs? Or a camp of Dark Elves? I can't specifiy that anymore.

    [This message has been edited by Angel Draco (edited 06-14-2002 @ 01:52 PM).]

  • posted 06-15-02 03:52 AM EDT (US)     6 / 56  
    I have the same problem as you Draco. Adding items to a hero in the editor is a pain in the butt. All the items end up going in the wrong slots, and then when you remove the items from the hero to try and fix them, it says that the items are still in use, so you cant assign them again! This is extremely frustrating and needs to be fixed.
    posted 06-15-02 04:47 PM EDT (US)     7 / 56  
    I make a new library of items, create an done than my computer crash, not only the editor but the computer...I tryed twice and it did that twice... very frustrating.
    posted 06-15-02 05:19 PM EDT (US)     8 / 56  
    same problems here, draco.

    you can use the cursor keys to move back and forth if the library is 5 boxes wide.

    also, when i maximize the editor, it leaves about an inch of desktop space at the top of the screen, and the bottom inch of the editor gets hidden behind the task bar.

    here's a screen shot if anyone cares. notice that the buttons in the upper right are minimize, restore, and close, yet you can see my desktop image. i can't drag the window, because windows is under the impression that the window (whoa, too many "windows") is maximized.

    [This message has been edited by pataphysician (edited 06-15-2002 @ 05:21 PM).]

    posted 06-15-02 08:35 PM EDT (US)     9 / 56  
    Here's an example of the Hero Properties screen all messed up when trying to add items: Hero Properties Bug

    This needs to be fixed immediately IMO. It's impossible to make custom heroes with items as it stands right now.

    Here's the problem with the portraits being too wide:
    Port Prob 1 (in the red circle, you can see the sliver of the next set of portraits).
    Port Prob 2. Clicking on that sliver cicled above moves everthing over, but now you can't go back unless you use the curors as pointed out above.

    This is impractical for two reasons: (1) Someone could easily miss the extra portraits; (2) It's not made readily apparent you can use the arrow keys to move back and forth (i didn't know until it was pointed out above). Why not just add more portraits below the first four? Plent of room there.

    posted 06-16-02 05:09 PM EDT (US)     10 / 56  
    Basic terrain keys (ice, snow, grass, road/bridge. etc.) sometimes look like they're not selected when they are and vice versa.
    posted 06-18-02 00:20 AM EDT (US)     11 / 56  
    When I add items to Heroes, the editor interface looks wrong, but the items are correct in-game, and if I close and re-open the hero dialog in the editor...

    Points noted.

    Josh Farley
    Triumph Studios
    posted 06-18-02 10:38 AM EDT (US)     12 / 56  
    I have added a custom hero with a custom item to the map I am playing around with. In game play, the hero shows up in the correct location, but the item is missing from his inventory.

    I just began playing with the editor, so I am not sure if it is the custom hero or custom item that is giving me the problem. I can tell you that if I place the custom item next to the hero on the ground instead of in his inventory, everything is OK.


    posted 06-21-02 12:02 PM EDT (US)     13 / 56  
    User-made libraries do not seemed to be saved and are lost upon exiting the editor.

    User-made library problems posted:,39,0,60

    Verification test to illustrate:

    Load or make test map
    Make library
    Save Map
    Exit AoW2Ed
    Restart AoW2Ed
    Load any map
    Check for Library

    "Where there is imagination, the possibilities are endless."
    Age Of Wonders 2 Heaven | AOW2H Scenario Designers' Hall

    [This message has been edited by Bluecollarheaven (edited 06-21-2002 @ 12:12 PM).]

    posted 06-24-02 04:10 PM EDT (US)     14 / 56  
    When opening a scenario, the campaign maps are listed as valid file types, and I can open the Tutorial scenario without any problems; however, when I try to open any other campaign scenario, nothing happens. (No editor windows, no error messages, nothing whatsoever.)
    posted 06-25-02 04:04 AM EDT (US)     15 / 56  
    Blue - create a dir named "User" in the main aow2 directory.

    Josh Farley
    Triumph Studios
    posted 06-26-02 00:13 AM EDT (US)     16 / 56  
    Hmm, it's looks like my previous post is deleted.

    I have WinME OS and the editor is ALMOST not working in my computer - I usually can make 2-3 actions like adding hero or even scrolling the map before program crashes. Sometimes editor has generate an errors in status line (?) and after this it is possibly to save map but other actions are almost not possible.

    It is strange because the main game executable is working fine.

    posted 06-28-02 12:09 PM EDT (US)     17 / 56  
    My machine just locks up whenever I try to make a new map and select medium, large or extra-large in combination with underground level.
    Yet, there is a work-around: creating a surface level-only map of any size, and then, while editing it, adding the underground level, works. It does take 5 seconds for the program to finish adding the new level.

    Steel Monkey
    posted 06-28-02 04:07 PM EDT (US)     18 / 56  
    I've encountered two Editor bugs so far that pretty much make it too aggravating to even bother using.

    1) There's an FPS counter in the upper left hand corner. This wouldn't be a big deal except it flickers very rapidly and is VERY distracting.

    2) The editor has seemingly random times when it will 'freeze' up - the FPS counter stops flickering and reads at less than 1 FPS, usually less than .5 FPS. Once this starts (which usually doesn't take long at all) it will continue freezing every few seconds until I exit the program and start over again.

    My system is 1.4Ghz P4, GeForce 2 64MB video memory (latest drivers), 256MB RAM, running on Windows XP Home edition.

    posted 06-28-02 05:01 PM EDT (US)     19 / 56  
    you can hit F9 to hide the FPS counter.
    posted 07-03-02 02:56 AM EDT (US)     20 / 56  
    F9 isn't work.

    *** Sorry 4 my English
    posted 07-04-02 07:46 AM EDT (US)     21 / 56  
    F9 works, but you have to click on the map in the editor first to make sure the map is selected.
    posted 07-05-02 01:58 PM EDT (US)     22 / 56  

    It's possible to make that's LARGER then a small/medium/large map.

    Just place a "lava transition tile" on a empty tile (void, with the stars and stuff). Now you can place whatever you like there :/

    I'm pretty sure this is a bug.


    It's possible to place cavern tiles above ground, but it's not possible to place dirt tiles above ground... :/

    posted 07-08-02 05:30 PM EDT (US)     23 / 56  
    Placing underground wall above ground near the edge of the map causes the space lookin' area to turn into a wall. You can delete it and then put whatever you want there. And, if I remember correctly, if there is water by the edge of the map and you place an underground wall it causes the water to be elevated. It is a bit odd seeing a pyramid of water taller than all that mountains in your map...

    And when I did this, on the map I made all the units in the game refused to move no matter what I did after around 20 turns. Don't know if that was the cause though.

    posted 07-13-02 03:40 PM EDT (US)     24 / 56  
    Editor continues to freeze despite turning off counter(F9)and continually posts message of access violation at address 006438A0 in module AOW2ED.exe. No screen saver; power save off; use direct 3D off; NVivida w/latest driver (worked better before loading this driver); Norton disabled; MSN messenger off; I have loaded the Editor on two different PCs with almost identical results (except it crashed the 2nd PC and which now refuses to even boot in safe mode).
    Operating System: Microsoft Windows XP (5.12600)
    DirectX Version: 8.1 (
    Desktop Resolution: 1024x768x16
    Physical Memory: 95 / 255 MB
    Virtual Memory: 1921 / 2047 MB
    Winsock 2 Detected: YES

    AoW2 Version: 0.91

    Resloution Switching: On
    Detail Level: Highest
    Cursor Mode: Black & White
    Sound: On
    Music: Off
    DirectSound: Off

    Pentium IV 1700; 255 ram; NVidia GeForce2;
    I have CIV III & HOMM IV both games/editors work fine with no problems. What in my system is conflicting with AOW?

    posted 07-13-02 04:05 PM EDT (US)     25 / 56  
    Another problem: when you wish to place events to trigger, you can click on that tab (upper right-hand corner), but how to get back to where you can place tiles/units/places etc.? Plus, just when I click the events tab, the minimap starts behaving strangely, popping up in the upper left-hand corner, and covering up the buttons underneath it permanently.
    posted 07-15-02 06:22 AM EDT (US)     26 / 56  
    Cannot work with editor.
    After loading or creating a map and making 2-3 actions or just scrolling the map, map tiles fill menus and other parts of editor window, and it becomes completely unusable.
    Looks like driver issue, but I have no porblems in game, and I don't see a reason to use hardware acceleration in the editor.
    posted 07-15-02 06:07 PM EDT (US)     27 / 56  
    Just ran scandisk and found all the maps I had been working on were cross-linked with other files on my pc. I don't know enough about computers to understand how this happens but those were the only errors found
    posted 07-15-02 11:53 PM EDT (US)     28 / 56  
    A Quest question:

    When making a quest, it asks for days, like earliest and last days, which I assume is the start and end points, but quests always seem to fail if not completed in ten days. Is this a bug?

    Is this supposed to be used to determine the length of the quest (which I hope, because that would make sense, being able to dictate the amount of time a player has to complete a manually created quest) or is it just a space for saying "this is the earliest day the quest can be given, and this is the latest day, and if the other trigger conditions are not met by the last day, no quest, and if they are met earlier, quest will not be offered before earliest day."???

    [This message has been edited by orionshaolin (edited 07-16-2002 @ 07:44 PM).]

    posted 07-16-02 10:53 PM EDT (US)     29 / 56  
    As for the selecting portraits:

    You do not need to click on the mostly-off-screen portraits, as your arrow keys work fine here.

    Experiment a little, people. =P

    posted 07-19-02 06:49 PM EDT (US)     30 / 56  
    weeelll, i played an old world war 2 scenario for the aow1 many times. and there were boats. lots of em...
    they moved around, attacked, transported people.
    i made a scenario on a world war...with boats.
    they don't move. the AI is set to Emperor, i think that means the AI should be smart enough to realize boats are something you move around, not having positioned like some off-shore fortress or something.
    I guess i could set the boats to "patrol" or something, but it's still not like the AI would use them in any "intelligent" way. i think that smells. i'd like the AI to know what boats are. cus' boats rock.
    cheers to everyone playing this wonderful game
    « Previous Page  1 2  Next Page »
    Age of Wonders 2 Heaven » Forums » AoW2 Technical Help » Scenario Edtior Bugs & Anomalies
    You must be logged in to post messages.
    Please login or register
    Hop to:    
    Age of Wonders 2 Heaven | HeavenGames