You must be logged in to post messages.
Please login or register

AoW1 Mod Packs
Moderated by Enginerd, Ziggurat Mason

Hop to:    
Topic Subject: Warlock ruleset 64-bit installation
posted 10-10-11 02:03 PM EDT (US)   

I've read through the topics here for warlock ruleset 64-bit.

I downloaded the mod + 64-bit files, opened the rules2.bat clicked enter until it shut down.
It installed WR-maps, no errors etc. But I cannot find how to make it work.

I tried to shortcut it as told rules2.bat -> Warlock. Then play through the normal aow shortcut.

I tried to check whatever it uses the old or new rules, but based on the spell-costs the old rules are still on use.
How do I see that the warlock rules are on? Which stats I can immediately see that the new rules are in use?
Did I install it correctly? I'm bit confused about those old introductions because the rules.bat does not open at all, and the rules2.bat only once when you install it on the first time.
I dont use the steam release.
posted 10-10-11 02:42 PM EDT (US)     1 / 4  
Check which version of the exe file you have (it's displayed in the bottom right corner of the title screen). Warlock's mod works with 1.36.0053, but not with 1.36.0054 (which I have)

A proud member of the Unofficial Patch team.
Creator of the AoW1 Mod.
posted 10-10-11 07:46 PM EDT (US)     2 / 4  
Warlock's mod works with 1.36.0053, but not with 1.36.0054 (which I have)
Finally an explanation for why I was unable to use the Warlock's Rules Mod! (I too have AOW version 1.36.0054).
posted 10-11-11 01:40 AM EDT (US)     3 / 4  
Thanks for the quick answer. I seem to have 1.36.0053.

Correct me if I have done something incorrect:
I downloaded the warlock mod pack.
Unzipped it in main AOW folder.
Then I downloaded Warlock 64-bit update files. Extracted them in Aow folder.
Then I ran the rules2.bat. It said all the time "press any key to continue" and it installed some files. Then it automatically shut down in the end.

Then it should work? I dont know how how to make this step without DOS:
The patch will now be compiled and ready.
However, the patch does not initialise Warlock's Rule-Set by default, everything will work exactly as it did prior to this installation.
To play with the new rules type:
Rules Warlock [enter]
Then start the game.
To go back to the original rules type:
Rules TS136 [enter]"

Edit: from new WL-maps the second one works, but not with the modified spell costs etc.

EDIT 2: Problem solved!
I used Rule changer to switch on the mod, and it worked fine.
I recommend others also to try that if you have problems with 64-bit system.

[This message has been edited by xheksix (edited 10-11-2011 @ 12:02 PM).]

posted 05-19-13 04:02 AM EDT (US)     4 / 4  
Where did you find these 64-bit files, xheksix?

Edit: nm


[This message has been edited by hippox78 (edited 05-19-2013 @ 04:04 AM).]

Age of Wonders 2 Heaven » Forums » AoW1 Mod Packs » Warlock ruleset 64-bit installation
You must be logged in to post messages.
Please login or register
Hop to:    
Age of Wonders 2 Heaven | HeavenGames