You must be logged in to post messages.
Please login or register

AoW1 Technical Help
Moderated by Enginerd, Ziggurat Mason

Hop to:    
loginhomeregisterhelprules
Bottom
Topic Subject: Map+Draw errors
posted 05-06-01 00:35 AM EDT (US)   
Whenever I try to enter a city or guild in a scenario, the game hangs and I get an infinite number of looping Draw or Map errors and I have to Cntl-Alt-Del my way out. I'm currently running Win98 with the DirectX that was loaded on the Medieval Masters Tzar/AOW CD (DirectX CD). I'm trying out DirectX 8.0a to see if that helps at all.

Any help out there?

-newbie revalos

Replies:
posted 05-06-01 04:24 AM EDT (US)     1 / 31  
You might try running the game from a fresh reboot, with all background tasks manually shut down... If the problem persists, reinstalling the game from the same "boot & shut down BG tasks" setup may help... Checking for newer video card drivers is another possibility...

Hope something in there helps


Josh Farley
Programmer
Triumph Studios
posted 05-06-01 09:35 AM EDT (US)     2 / 31  
Thanks for the quick response!

I spent about 2 hours this morning searching for driver file updates to my video card (STB Velocity 128 AGP) and I finally got them from nVidia, but when I attempted to update the drivers, I was told I already had the best driver files for the video card. I guess this is possible, but oh well, check that off the list.

As to your suggestion that I reinstall the game using the "boot & shut down BG tasks" setup...well I don't quite know how to do that. I can't imagine it would be a background program interfereing, but I'm willing to try.

As for starting after a fresh reboot, I've been there done that, no changes.

Here's a better description of the problem:

Start AOW
Select Scenario
Choose Mine all Mine
Choose Dark Elves
Go into the Cave
Go to the Guild on the right hand side
Click Enter on the enter guild screen
++++Nothing Happens
Alt-Tab back to desktop
There is an "Error - Map View" window that says "Exception during Draw" and an OK button.
I click it, the game pops back up...but it is a black screen
Alt tab back out, the same error window is there
I then right click on the taskbar AOW pogram and try to close it.
This does nothing, the game immediately pops back up as a black screen.
However, a new error window pops up when I alt-tab back.
It is titled "Error - Shadowl" with the same internal text
Then after clicking ok and Alt-tabbing from a black screen the window changes to Error - ShadowR, but then the whole computer hangs and I have to hot boot the system.

I hope I can fix this!

-Revalos

posted 05-06-01 03:36 PM EDT (US)     3 / 31  
I am also experiencing similar bugs. I purchased AoW in the "Medieval Masters" collection.

I get "Exception During Draw" errors when entering Nementh in the "After the Fall" scenario and Kinstar in the "Flowershire" campaign scenario. The Nementh bug is especially bad because it makes the Orcs unplayable in that scenario, since it's the starting city for the Orcs.

I also get "Exception during MapViewer.ShowScene" errors in certain hexes when a tactical battle starts. In the Flowershire scenario, this happens in Kinstar and also in a hex one hex north and one hex east of the tower that is south of Kinstar.

I do have the latest video drivers. I also have heaps of memory on all three of the computers I duplicated these errors on, so it shouldn't be a memory issue.

Systems I have replicated this bug on:
Windows 98, 128MB PC-100, ATI Rage 128 (16MB), P-II 300Mhz
Windows 98, 256MB PC-133, NVidia GeForce DDR (32MB DDR), Athlon 1Ghz
Windows 2000 Server, 128MB PC-100, ATI Mobility (8MB), P-III 600Mhz

posted 05-06-01 03:38 PM EDT (US)     4 / 31  
Oh, I forgot to add that I can provide sample saved game files if necessary. If you need them, send a request for them to comments@bubandbob.com.

[This message has been edited by Bubicus (edited 05-06-2001 @ 03:39 PM).]

posted 05-06-01 03:48 PM EDT (US)     5 / 31  
I also got the Medieval Masters Collection. Perhaps that's where the bug lies?

I also remembered another draw error on the tutorial in one of the battles as well.

I've duplicated the bugs on two computers on the low end as well:

WIN 98 128MB ram STB Velocity 128 4mb
WIN 98 64MB ram ATI TV/Rage pro

Glad it isn't just me.

-revalos

posted 05-07-01 03:29 AM EDT (US)     6 / 31  
This does seem like an installation problem... to shut down background tasks, use the Ctrl-Alt-Del menu...

This can be especially important with the Installshield installers, which can have serious problems with background apps that filter files (like virus scanners, etc)...


Josh Farley
Programmer
Triumph Studios
posted 05-07-01 09:01 AM EDT (US)     7 / 31  
OK, I uninstalled the entire Medieval Master's Collection, then using the Cntrl-Alt-Del menu, I ended all the tasks on there, except Explorer. I then reinstalled the game under those conditions. However, the problem was still there looking exactly the same as it had before.

Could Explorer be the problem? Can I shut it down too? I'm not too savy with background applications.

Thanks again for trying to help me out Josh, Y'all get an A+ for customer support for a game that has been out for quite some time. You should see the hoops I had to go through to get support for some other games made around the same time.

-revalos

posted 05-07-01 02:37 PM EDT (US)     8 / 31  
I get those same errors... its only when I go from one campaign scenario to the next though. I reinstalled the game, and it does it LESS often but still does it. But I just Alt-Tab to the little error box, click OK and keep rolling.

-Stephanos

My Freeware Adventure Game: http://stephanosquest.cjb.net
The Robotech Freespace 2 MOD: http://robotechlan.com/freespace2

posted 05-07-01 07:02 PM EDT (US)     9 / 31  
Hmm, you might try playing the game in windowed mode, turning off sound, etc... basically tweaking settings to see if anything improves the situation...

But I still suspect the installation as the source of the problem... make sure there's plenty of HD space on the destination drive, and the drive holding your swap file ( probly C:\ ). Also, be sure to reboot between the uninstall and reinstall.

You might also reinstall DX8 after completing the installation...


Josh Farley
Programmer
Triumph Studios
posted 05-07-01 07:47 PM EDT (US)     10 / 31  
Josh may remember that i had a problem reinstaling AoW on a new HD, i Downloaded DX8 and go it to work plus i had a conflick with my sound card drivers, dont know which one got it to work or both. also is the AoW in this medieval package vers. 1.36? But the only time i have map draw error, or run time errors is when i ctrl+ alt+del to exit AoW; when some drops in Mplay, then i just reboot and works fine. hope you can get it fixed.


420
SL/AoW Admin

posted 05-07-01 11:33 PM EDT (US)     11 / 31  
Medieval Master's version is 1.360054 I believe, one interesting thing is that if you try to run the 1.36 update and run AOW it asks for the AOW CD. It then does not recognize the MMC CD with AOW and Tzar as the AOW CD and the game will not run at all.

OK...This is what I've tried

reinstalled, then reinstalled directx
reinstalled then tried windowing w/sound
reinstalled then tried windowing w/o sound
reinstalled then changed resolution with sound
reinstalled then changed resolution w/o sound

What other settings can I try?

My swap file is on the C drive and is at 288 MB. I could change it to another drive with 1+ gigs of space, but 288 mb seems like a pretty big number, I am currently using partitions, so I'm not sure if that would cause my system to become unstable.

I've found many many more places where the game will hang with the same errors:

entering two cities in Flowershire
fighting outside the large goblin city in flowershire
entering most any city in the underground passage
fighting any inhabitants in the underground on tactical mode

I have not seen any change in the scenario error either with any of the settings alterations.

what settings do y'all have that work?

-revalos

[This message has been edited by revalos (edited 05-07-2001 @ 11:38 PM).]

posted 05-08-01 03:21 AM EDT (US)     12 / 31  
The 1.36 patch is not designed to be used w/ that CD (which already contains a 1.36 exe)... In fact, I believe the AoW.exe in the bundle does not even check for a CD, so you really shouldn't be patching it...

There should be no need to reinstall between settings changes...

You might try a reinstall of DirectX and/or sound/video drivers...

And that swap file size could cause problems, especially if the recycle bin is pretty full... You might try moving some files around to increase the free space on your C drive before trying another reinstall... 288MB should be plenty, but I do know that the InstallShield installers are pretty big resource hogs...


Josh Farley
Programmer
Triumph Studios
posted 05-08-01 01:20 PM EDT (US)     13 / 31  
Each of the three computers I had trouble on have well over two gigabytes of available swap space. I don't think swap space is a factor in the bug.

I doubt it could be a problem with graphics card drivers since all three of the computers I have seen this bug on have the latest drivers, and they all have different graphics cards.

Realistically, if it is always THE SAME locations that are causing the problem, then it is most likely a bug with the way that the tactical map generator creates a map based on the underlying terrain. I found another bad location yesterday: on "Assassination", the mine above your starting position causes the crash (an elf had captured the mine and I was attacking it). This location generates the "MapViewer.ShowScene" error, followed by a "Blt Error" and then an unending stream of "MapViewer.ShowScene" errors.

posted 05-08-01 01:27 PM EDT (US)     14 / 31  
I can also vouch for the pretty high possibility that swap files are not the problem, I got up to 500 mb freed on the C drive and still saw the same problem. I also reinstalled DirectX and installed the game after a fresh reboot. I've tried with sound and no sound. Nothing changes the errors.

I agree with Bubicus, because these errors don't happen everywhere, they happen in particular locations and are either associated with tactical battles in certain hexes or clicking on enter in the city command window, that it might be a software error more than a driver error because everything else in the entire game works just fine, it is just certain locations, some of which are quite important, that always have the same error.

-revalos

posted 05-08-01 02:02 PM EDT (US)     15 / 31  
I've posted save files to bubblebobble.org that you guys can try to duplicate the errors with.
http://www.bubblebobble.org/MineError.acg (attack the elf to cause a bug)
http://www.bubblebobble.org/OrcError.asg (enter the city to cause a bug)

posted 05-08-01 02:53 PM EDT (US)     16 / 31  
I tried the OrcError save file, and it works fine for me (I have the original game, patched to 1.36).

I've read the same problem descriptions at the Lifeline forum (from the same people?), and I don't remember any of these problems from when the original game was released. To me it sounds like there's something's wrong with the Medieval Master's version of the game. If so, I'm sure Triumph will have a patch ready shortly!

posted 05-08-01 02:59 PM EDT (US)     17 / 31  
Heh...yeah, I know we're talking about this in two BBS's but I think we want maximum visibility to try to get a patch or something to fix it.

I've tried the savefiles and they crash on my computer.

-revalos

posted 05-08-01 07:15 PM EDT (US)     18 / 31  
Well, you'll have to forgive for not responding on both forums... :P

I'm still wondering about the installer, as that's the main difference between your version and the others. A missing/corrupt file would cause exactly those errors, and would only happen if the map caused those files to be accessed...

You might go through your AoW dirs and subdirs (especially Images\), and see if there are any files with a size of 0...

If not, it would be helpful if you could post the # of files in each dir (maybe a total HD usage # for each dir as well, but that's not as important)... This should tell us if the installer has installed all the correct files.


Josh Farley
Programmer
Triumph Studios
posted 05-08-01 09:28 PM EDT (US)     19 / 31  
So, Josh, you are saying this is the best board?

-Stephanos

My Freeware Adventure Game: http://stephanosquest.cjb.net
The Robotech Freespace 2 MOD: http://robotechlan.com/freespace2

posted 05-08-01 11:06 PM EDT (US)     20 / 31  
OK 1 board it is...here's a listing of the numbers of files in the directories

f:\medieval\Age of Wonders\ 14.5 MB
40 Objects, 13 subdirectories

f:\medieval\Age of Wonders\DICT\ 111 KB
1 Object

f:\medieval\Age of Wonders\EIDMAGES\ 0
0 Objects

f:\medieval\Age of Wonders\EmailIn\ 0
O Objects

f:\medieval\Age of Wonders\EmailOut\ 0
O Objects

f:\medieval\Age of Wonders\Images\ 11.3 MB
77 Objects, 11 subdirectories

f:\medieval\Age of Wonders\Images\Effects\ 18.4 MB
22 Objects

f:\medieval\Age of Wonders\Images\Faces\ 4.91 MB
4 Objects

f:\medieval\Age of Wonders\Images\Items\ 224 KB
7 Objects

f:\medieval\Age of Wonders\Images\Mountain\ 624 KB
3 Objects

f:\medieval\Age of Wonders\Images\Races\ 1.93 MB
12 Objects

f:\medieval\Age of Wonders\Images\Scenes\ 90.0 MB
1 Object

f:\medieval\Age of Wonders\Images\St\ 178 KB
10 Objects

f:\medieval\Age of Wonders\Images\Tcombat\ 927 KB
4 Objects, 8 Subdirectories

f:\medieval\Age of Wonders\Images\Tcombat\Base_hex\ 796 KB
18 Objects

f:\medieval\Age of Wonders\Images\Tcombat\City\ 2.17 MB
25 Objects

f:\medieval\Age of Wonders\Images\Tcombat\De\ 158 KB
9 Objects

f:\medieval\Age of Wonders\Images\Tcombat\Expl\ 884 KB
12 Objects

f:\medieval\Age of Wonders\Images\Tcombat\Gr\ 333 KB
17 Objects

f:\medieval\Age of Wonders\Images\Tcombat\Objects\ 1.00 MB
12 Objects

f:\medieval\Age of Wonders\Images\Tcombat\Sn\ 182 KB
10 Objects

f:\medieval\Age of Wonders\Images\Tcombat\Struct\ 909 KB
8 Objects

f:\medieval\Age of Wonders\Images\Ug\ 122 KB
8 Objects

f:\medieval\Age of Wonders\Images\Units\ 533 KB
2 Objects, 17 Subdirectories (I won't expand them here to save space since I don't think this has to do with units)

f:\medieval\Age of Wonders\Images\Wl\ 191 KB
10 Objects

f:\medieval\Age of Wonders\Int\ 12.5 MB
38 Objects, 2 Subdirectories

f:\medieval\Age of Wonders\Int\Fonts\ 303 KB
13 Objects

f:\medieval\Age of Wonders\Int\Scenes\ 37.1 MB
37 Objects

f:\medieval\Age of Wonders\Release\ 1.9 MB
15 Objects

f:\medieval\Age of Wonders\Save\ 287 KB
Not listed

f:\medieval\Age of Wonders\Scenario\ 0
0 Objects, 2 Subdirectories

f:\medieval\Age of Wonders\Scenario\Campaign\ 1.62 MB
43 Objects

f:\medieval\Age of Wonders\Scenario\Custom\ 858 KB
23 Objects

f:\medieval\Age of Wonders\Sfx\ 0
6 Subdirectories (not expanded to save space)

f:\medieval\Age of Wonders\Songs\ 16.7 MB
20 Objects, 2 Subdirectories (not expanded)

f:\medieval\Age of Wonders\TCMaps\ 292 KB
59 Objects

f:\medieval\Age of Wonders\User\ 0
0 Objects

Whew...that's all of them, if you want me to expand the other directories, I'll do so. No files of 0 size were found.

-revalos

[This message has been edited by revalos (edited 05-08-2001 @ 11:12 PM).]

posted 05-09-01 00:16 AM EDT (US)     21 / 31  
Here are my directory contents:

(Just file count and size) http://www.bubblebobble.org/dirsimple.txt

(Entire contents of the Age of Wonders directory -- what I assumed Josh means by "total HD usage # for each dir" :-) ) http://www.bubblebobble.org/dir.txt


Here's the results I got:
Total files listed:
967 file(s) 310,434,510 bytes
185 dir(s) 5,061.13 MB free

Minus the saved game directory:
8 file(s) 822,715 bytes

Is this close to the expected folder size? Is the file count correct?


posted 05-09-01 00:27 AM EDT (US)     22 / 31  
You may have something there about the installer. I just noticed that if I try to run Aowed, I get an error message about "splash.bmp" missing. If the install package is missing a BMP, maybe it's missing other things...?
posted 05-09-01 00:59 AM EDT (US)     23 / 31  
I see some problems... can you verify the following?

f:\medieval\Age of Wonders\EIDMAGES\ 0
0 Objects

^^^ empty? A splash bmp should be there, although it isn't necesarry...

f:\medieval\Age of Wonders\Images\St\ 178 KB
10 Objects

f:\medieval\Age of Wonders\Images\Ug\ 122 KB
8 Objects

f:\medieval\Age of Wonders\Images\Wl\ 191 KB
10 Objects

^^^ Those paths are correct??? All three of those Dir's should be in the TCombat directory... if they aren't, you should move them there to correct a LOT of probable problems...

LMK how this goes, we may have tracked down the problem...


Josh Farley
Programmer
Triumph Studios
posted 05-09-01 06:56 AM EDT (US)     24 / 31  
Josh....YOU DA MAN!

After changeing the directory structure, Builder's Guild in Mine all Mine no longer crashes, I haven't tried the save files, but I'm going to hazard a guess that they work too. I'm also missing the Splash BMP, I get that message every time I load the editor.

-revalos

posted 05-09-01 03:40 PM EDT (US)     25 / 31  
I'm glad to hear your game is running more smoothly now. Our apologies for any inconvenience this has caused. Any other users experiencing these problems with the "Medieval Madness" version of AoW can likely correct it by moving the dir's listed above, or can wait for a patch, which will be released shortly.

Glad I could help!


Josh Farley
Programmer
Triumph Studios
posted 05-10-01 00:31 AM EDT (US)     26 / 31  
Likewise, this fixed the errors on my system. Way to go, Josh! Thanks to you, too, Revalos!
posted 05-10-01 12:41 PM EDT (US)     27 / 31  
Thanks to you too Bubicus, 1 person with a problem can sometimes not be heard as well as two. Hey Josh...you said a patch is forthcoming...should I move my directories back the way they were and install that patch when it comes out? Or should I not worry about patching?

-revalos

posted 05-10-01 06:57 PM EDT (US)     28 / 31  
The patch is just going to put those files in the right place, and give you the splash.bmp for the editor. There's no reason to change anything on your system... If you want to remove the nagging error msg when the editor starts up, you should grab the patch. Otherwise, you're good to go...

Josh Farley
Programmer
Triumph Studios
posted 07-07-01 07:40 PM EDT (US)     29 / 31  
I`m getting this error message: "Exception during MapViewer.ShowScene" whenever theres a map containing wastelands graphics, so the problem is with an *.ilb which was probably somehow corrupted... Can someone send me that file or at least tell me the filename?

Tnx a lot. My email - ilya001@hotmail.com

posted 07-08-01 11:53 AM EDT (US)     30 / 31  
The patch didn't fix everything. I still get the mapview crash on Serpent River scenario when attacking the 4 hex orc city near the starting point. More graphics in the wrong place.
posted 07-08-01 09:59 PM EDT (US)     31 / 31  
Nevermind, my bad. I had just put the game on my laptop (it was already on my main PC), and the patch didn't extract properly. Problem solved.
Age of Wonders 2 Heaven » Forums » AoW1 Technical Help » Map+Draw errors
Top
You must be logged in to post messages.
Please login or register
Hop to:    
Age of Wonders 2 Heaven | HeavenGames