You must be logged in to post messages.
Please login or register

AoW:SM Tech Help & Bug Reporting
Moderated by Swolte, Ziggurat Mason

Hop to:    
loginhomeregisterhelprules
Bottom
Topic Subject: So, has this Direct3D problem been resolved, or ...
posted 09-06-13 05:15 PM EDT (US)   
Hi folks,

so after the announcement of Age of Wonder III, i decided to warm myself up a little by playing through Shadow Magic again.
So i installed it to my newest machine, installed the latest patch + the unofficial one, max the settings, started it up and ... wondered why it runs so choppy.

I've done a lot of research around this. I know but simply refuse disabling the direct3d-feature to solve this since it turns the game ugly.
I tried installing it on a VM, but it won't start.
Strangely enough, if i tab the game down and bring it up again, it runs smoothly. But it glitches up the Interface.

All the threads i was able to find suggested to simply disable direct3d. Thats not a solution for me so i desperately ask again: Do anyone know how to fix this?

Some people blamed the video card drivers. I have a GTX 680 built in and, of course, run the latest drivers. So i don't think this is the problem.

Regards
Mediin
Replies:
posted 09-07-13 01:43 AM EDT (US)     1 / 6  
Switch compatibility to Windows NT 4.0 (Service Pack 5) and disable Desktop Themes.
It applies to AoWII too.
posted 09-07-13 06:28 PM EDT (US)     2 / 6  
Wow, thank you very much.

Disabling the desktop themes in Windows 8 is kinda stressfull, but it actually worked.

For everyone who wants to play this game on Windows 8 in all his full direct3d glory, you have to set compatibility mode to Win98/ME, have to disable all visual effects, restart the pc, kill explorer.exe, suspend winlogon.exe, kill dwm.exe and then start Shadow Magic.

Hoboy. I may set up a more customer friendly solution for Win8-Users, but now, i enjoy the game.
posted 09-07-13 06:44 PM EDT (US)     3 / 6  
Glad to be (partially) helpful
Looks like BIG trouble on Win 8, but it works - that's what matters.
And to think that I was preparing to change for Win 8, better wait some time.
posted 12-05-13 09:22 AM EDT (US)     4 / 6  
Your bug looks to be another thing, but AoW2 and SM have this - rather common - bug:
http://my.opera.com/Vorlath/blog/2009/02/01/directx-d3d-mouse-lag

The game actually 'queues' commands to render frames much much ahead of displaying them, and they aren't discarded by default, so if your cpu is very powerful compared to your graphics card (say, if you're running on wine - which needs to do Bits per pixel conversion and on open graphic drivers - which tend to be slower) then you'll be hit full on with obscene 1 second+ lag, which most people think is the game being slow but it's actually it being too fast from running as fast as it can and queuing frame updates much ahead of actually displaying them from the overworked GPU that can't keep up so is buffering dozens of frames. Thus the infamous 'floaty' mouse cursor, the lag on interface elements where you can hear the sound of clicking on the buttons (CPU) before you actually see the confirmation (GPU), etc.

I had hopes that the MPE code patch could jigger the main loop frame rendering to prevent this, but Hellbrick doesn't want to touch that code.

[This message has been edited by i30817 (edited 12-05-2013 @ 09:30 AM).]

posted 10-03-15 09:13 AM EDT (US)     5 / 6  
I'm under wine on xUbuntu, without any fancy adjustments. AoW:SM runs nicely (except mouse cursor is displaced down, but got used to it, and paying attention to tooltips helps) even in fullscreen 1920x1080. So... dual boot time?

And even I make no pretence Of having more than common sence - R.W.Wood
The secret half a country keeps, the whisper in the lane... - R.Kipling
[UPatch 1.4 Team] * STLpack
posted 02-01-16 10:10 AM EDT (US)     6 / 6  
Just discovered it, and thought that could help. I too experienced that Direct3D problem, and after a long time trying a bunch of different things, it turns out that a very simple thing did it for me, so here it is, in bold so everyone can jump right to it.

Type CTRL+R twice

CTRL+R toggles between hardware and software rendering modes. Starting the game with D3D disabled (soft) then typing CTRL+R seems to do the trick too. Better than killing DWM, eh ?
Age of Wonders 2 Heaven » Forums » AoW:SM Tech Help & Bug Reporting » So, has this Direct3D problem been resolved, or ...
Top
You must be logged in to post messages.
Please login or register
Hop to:    
Age of Wonders 2 Heaven | HeavenGames