You must be logged in to post messages.
Please login or register

AoW:SM Tech Help & Bug Reporting
Moderated by Swolte, Ziggurat Mason

Hop to:    
loginhomeregisterhelprules
Bottom
Topic Subject: Windows 7 64bit compatability.
posted 05-19-10 10:00 AM EDT (US)   
I was thinking of purchasing Shadow magic again. Does anyone know if its actually compatable with windows 7 64bit and my graphics card?

processer intel core i5 cpu 750.
Graphics card ATI RADEON 4800 HD
Replies:
posted 05-19-10 10:24 AM EDT (US)     1 / 12  
For me it works perfectly on Win7 64-bit.

I have a different processor and graphics card, but I don't think they would cause problems.

A proud member of the Unofficial Patch team.
Creator of the AoW1 Mod.
posted 05-19-10 07:42 PM EDT (US)     2 / 12  
Works for me too. Though it's not my PC, I once installed Aow:SM on a PC windows 7 x64 installed and didn't have any issue while playing.
PC configuration is not relevant, IMO, unless you don't have a DVD/CD drive to run the game


Tired of manually receiving/sending your PBEM turns everyday ? Try out Dave's PBEM Wrapper!
posted 05-20-10 07:33 AM EDT (US)     3 / 12  
works fine for me, too (on Win7/64Bit)
posted 08-02-10 10:08 PM EDT (US)     4 / 12  
Game is unplayable for me on win 7 64bit. Latest patch installed.

The mouse pointer leaves tracers all over the screen and the game is basically unwieldy. How do I fix this? Is this a threading issue?

[This message has been edited by Hybrisma (edited 08-02-2010 @ 10:09 PM).]

posted 08-03-10 04:48 AM EDT (US)     5 / 12  
That seems a graphics issue.
Can you check your DirectX settings and your graphic card driver?
If nothing wrong and you still have the issue, you can try to install DirectX 9 (i dont know if there is an 64 bits version).
posted 08-03-10 06:05 AM EDT (US)     6 / 12  
Or maybe simply you can try changing the "cursors" setting in the setup program...

A proud member of the Unofficial Patch team.
Creator of the AoW1 Mod.
posted 08-03-10 10:54 AM EDT (US)     7 / 12  
Ok I changed the cursor in the setup and that got rid of the tracers.

But the game is still unwieldy. Menus freeze on my screen and don't respond to my mouse clicks.

edit: Ok I turned off Direct 3D and everything seems smoother. I guess that was the problem.

[This message has been edited by Hybrisma (edited 08-03-2010 @ 11:01 AM).]

posted 11-10-10 02:39 AM EDT (US)     8 / 12  
i have no problem playing on win7 64, though map is flashing sometimes when moving around map. Its annoying but bearable.
posted 12-30-10 00:59 AM EDT (US)     9 / 12  
I recently got AoW2 because a friend recommended it to me, and I'm having a similar problem. The game installs but the screen freezes whenever I try to play it. I can tell that it is still running because the sound continues and the intro plays, I just cannot see any of it, or play the game itself because the screen of frozen. I read other post on this site and tried running the game with out my AVG but that didn't work. My computer is s new hp laptop with a intel i7 core that runs on Windows 7. What could be the problem?
posted 12-30-10 03:41 AM EDT (US)     10 / 12  
Hello,

First, you could try to disable 'Play intro' in AoWSetup.exe... I know it can cause problems...
posted 12-30-10 02:27 PM EDT (US)     11 / 12  
Thanks. I went into the configuring section of the game and changed the "play intro" settings, and that didn't work. Then i noticed that there was a box there about direct 3d that was disabled. When I enable it that game stopped freezing. I don't know if there will be future problems or not but at least it can be played now. Thanks again.
posted 01-24-14 07:32 PM EDT (US)     12 / 12  
This seems to be the most populated topic about Windows 7 issues, so I'll post my own experience here: got a new computer with this operating system, installed the game, patched it and then some scenarios and games wouldn't load properly, missing many, many graphical details.

The solution was to right-click the game's .exe file, click Properties, pick the Compatibility tab; then 3 things: 1) Windows XP SP3 compatibility, 2) disable desktop compositions and 3) run the program as system administrator.
Run very well now.
Age of Wonders 2 Heaven » Forums » AoW:SM Tech Help & Bug Reporting » Windows 7 64bit compatability.
Top
You must be logged in to post messages.
Please login or register
Hop to:    
Age of Wonders 2 Heaven | HeavenGames