You must be logged in to post messages.
Please login or register

AoW:SM Tech Help & Bug Reporting
Moderated by Swolte, Ziggurat Mason

Hop to:    
Topic Subject: Accessing save files in Windows Vista
posted 08-26-09 10:22 PM EDT (US)   
So yeah, I finished my turn, but when I want to attach it to the email nothing appears in the emailout folder execpt the dummy.txt, I made sure it was saved to the EmailOut folder of my Age of Wonders Folder. I think this might have something to do with another weird bug I have, where I have plenty of saves ingame but if I check out the saves folder in windows explorer nothing shows up, help?
If you have Windows Vista installed which is the most likely scenario, you should be aware that in Vista, the folder Program Files has access restriction. Depending on your user account, you might not be able to write (copy files to, save files to, create files within) to this folder. Those files that you've saved are not in Program Files but are in some 'virtual place'

One simple permanent solution is to install Aow:SM somewhere else, preferably in another partition (i.e. D: if you have more than one partition).

Other than that, you have to play the games as Administrator (right click on the game's shortcut to choose that). You will have to allow the UAC to let the game run as Admin... when you run the game as Admin, you can save the games to the "real" folder.

Now, to retrieve the saved file you've created, you need to go to the folder that you've supposedly saved the file (the folder named EmailOut). In this folder, you will see button "Compability Files" appear on the bar below menu bar or address bar.

Click on that button, your saved files will magically appear

For a further reading you can find it here. Credit to Hanselman for his useful page which helped me write this article.

Maybe, Swolte will sticky this one if you find the post useful and if it helps you solve the problem.

Edit: typo

Tired of manually receiving/sending your PBEM turns everyday ? Try out Dave's PBEM Wrapper!

[This message has been edited by naecO (edited 08-27-2009 @ 00:19 AM).]

posted 08-23-13 02:31 AM EDT (US)     1 / 2  
Thanks a lot for this question Necromagi, for the detailed and clear answer naecO and Hanselman for the basic information.
I run Win 7 and had the same problem but solved it with your help.

AoWSM Maps: 1. Marlenes Welt 2. Marlenes Schatten 3. Marlenes Gnade
Up.1.4 Maps: 4. Secrets of Marlenia (UPatch 1.4 Map - update) 5. Gates of Elocin - Part I (Mapmaking Competition - Winning Map) 6. Davidīs Winter Wonderland 7. Fairy Wedding
8. Marleneīs_Laughter 9. The Gods Arena Of Magic And Power 10. The_Wilderness 11. Kayland (AoW I Mod) 12. Mia-Mina_&_The_Seadrake
11. AoW I Sound Set for AoWSM 12. Gentleman Rules Set
Need Help? The Conqueror's Fieldguide to The Groll's Universe
Proud member of the Upatch 1.4, 1.5 & 1.6 Team

[This message has been edited by The Groll (edited 08-23-2013 @ 02:32 AM).]

posted 10-26-13 07:29 AM EDT (US)     2 / 2  
solution is to install Aow:SM somewhere else,

**** Framk ****
Age of Wonders 2 Heaven » Forums » AoW:SM Tech Help & Bug Reporting » Accessing save files in Windows Vista
You must be logged in to post messages.
Please login or register
Hop to:    
Age of Wonders 2 Heaven | HeavenGames