You must be logged in to post messages.
Please login or register

AoW:SM Tech Help & Bug Reporting
Moderated by Swolte, Ziggurat Mason

Hop to:    
loginhomeregisterhelprules
Bottom
Topic Subject: AoW, AoW2 and AoW:SM on Linux and OS X
« Previous Page  1 2  Next Page »
posted 11-02-03 01:07 PM EDT (US)   
Hi
I would love to run AOW:SM in Linux.
Any howto's, help, suggestions.

Thanks
Hobbledehoy

Edit: Corrected the thread's title - Daidalos

[This message has been edited by Daidalos (edited 08-10-2004 @ 04:02 AM).]

Replies:
posted 11-19-06 03:37 PM EDT (US)     31 / 54  
Hi everyone....
I've registered with only one goal actualy...
Some performance boost can be achieved by turning of the Direct3D use in game setup...
Quite a big boost for me actualy... With Direct3D the game was running unplayably slow.

PS I can't say, that it works good enough now, but it is at least playable.

posted 11-19-06 06:46 PM EDT (US)     32 / 54  
Unfortunately direct 3d seems to be required for seeing the projection paths of shots & breath attacks as well as round attack and so forth.

Something that can be useful in game for figuring out what units a multitile attack will hit or that a shot is being blocked by landscape ect as reason for it to miss or explode early.

It also effects other graphics but the rest are purely cosmetic as far as I know.

[This message has been edited by TruePurple (edited 11-19-2006 @ 06:50 PM).]

posted 11-21-06 02:08 AM EDT (US)     33 / 54  
Man I just wish Triumph can Release the Code under some Shared Licsense so that we can get Icculus to build a Client for Us.

Or Just give the Code to Him and Ask Him, I'm sure he won't mind

Maybe we should all just buy bigger Machines.(sure)

New Look Howto Updated: http://fischer.org.za/aow/

Karl


-------------------------------------
The Magical AOWSM Mac and Linux Howto
http://fischer.org.za/aow/
-------------------------------------
*HOME * SWEET * HOME*
http://fischer.org.za

[This message has been edited by Hobbledehoy (edited 11-21-2006 @ 03:17 AM).]

posted 01-23-07 10:21 AM EDT (US)     34 / 54  
hi all.

with the most recent wine 0.9.29 finally AOW1, AOW2 and AOW:SM all are playable in Linux (in my case Ubuntu 6.06 LTS).

big differences to the posts above:
1) AOW is playable with the regular opensource wine, without the you-have-to-pay-for Cedega.
2) at least AOW1 and AOW:SM install perfectly with the default installer, no need for complicated setups any more (still, thanks, guys for the aforementioned howtos).

working meants: perfectly playable on a 1GHz/512MByte machine (yes, I tested one of the Groll's maps). play-by-email works as does singleplayer (of course), I have yet to get hosting a multiplayer game to work in SM (in AOW1 there is already a nasty way with native DLLs for this...).

the intro movies have to be either skipped or disabled, but you hasn't by now anyway?

better yet, both AOW1 and AOW:SMs editors work fine. expect some maps from me soon. never too late starting mapmaking, right?

bye for now,
Poldi

posted 01-28-07 06:51 PM EDT (US)     35 / 54  
Well geting AOW:SM to work under wine didn't work for me very well...
But then I found a bash script to make it work.... So here is a solution for me... (btw... it works in Cedega but a bit slower and cedega is not free)
1) Disable the intro movie
2) Setup the game to run in a window...
3) run it with this script.

#!/bin/bash
RENICEMEPLEASE ()
{
sleep 2s
for a in `pgrep wineserver`; do renice 19 -p $a; done
}
RENICEMEPLEASE &
wine /path/to/game/AoWSM.exe

posted 02-04-07 06:01 PM EDT (US)     36 / 54  
Thanks for the script Waterlaz! I'm finally able to play my PBEM games on Kubuntu
I encontered one little annoyance though: after loading the game colours aren't displayed correctly, so I need to switch to full screen, where evertyhing works fine. Do you have any idea what may causing this?

Swimming out with the open sea... Like the great wild herring...
posted 02-05-07 04:04 PM EDT (US)     37 / 54  
Well.... I've tried to play the game today and found the same problem with colors. And I think I know what caused this problem. Yesterday I have switched my color depth to 24(was 16). Everything works fine in fullscreen but not in a window.
Don't know, how to fix it properly.
posted 02-07-07 04:23 PM EDT (US)     38 / 54  
After some tests with winecfg and aowsmsetup.exe I managed to run SM fullscreen, so there's no need to bother with bad colors in window mode.
Here's the best configuration for me (Kubuntu 6.10, Wine 0.9.30 and really old computer - Athlon 1200, 256MB, NVidia4). Of course I haven't tried all combinations, but this one gave me rally nice results (very good graphics, no problems with inactive cursor, quite good sound):

1. AoWSMsetup configuration:
Display mode: 1024x768 (full screen)
intro - no
resolution switches - no
d3d - - no
sound - yes
music - yes
direct sound - no
blood - certainly

2. Winecfg configuration:
Applications
Windows version - win xp
Librares - nothing added
Graphics
Allow DirectX apps to stop the mouse leaving their window - no
Allow the window manager to control the window - no
Emulate a virtual desktop - yes (1024*768)
Vertex Shader Support - hardware
Allow pixel shader - yes
Audio
OSS driver
Hardware acceleration - emulation
Default sample rate: 22050
Default bits per sample 8
Driver emulation - no

3. Waterlaz script
Wine desktop configuration: always on top, no window borders (to avoid problems with scrolling the map).


Swimming out with the open sea... Like the great wild herring...
posted 02-09-07 03:04 PM EDT (US)     39 / 54  
Well the game works fine in full screen. Except that the keyboard doesn't work.

PS in general there is a one major rule in running games under wine. You should use OSS instead of ALSA even if you have ALSA. ALSA can emulate OSS. But wine works with OSS much more stable.

posted 02-09-07 07:05 PM EDT (US)     40 / 54  
In my case keyboard works well... Are you using the same configuration?

Swimming out with the open sea... Like the great wild herring...
posted 04-09-07 08:24 PM EDT (US)     41 / 54  
Hi it took me 2 years to get AoWSM running on Linux:

BUT TODAY....... HURAAAAAAAAAAAAAAY
AoW SM - Dwiggs 4.5 with LAN / Internet on Ubuntu 6.10 EdgyEft....

1. Install wine 0.9.x
2. Install AoW SM with wine & run all patches or mod installs
3. Install & update Cedega Version 5.2.3 with cedega-engine-5.2.10-local-update.i386
4. Try to install AoW SM with Cedega, until Setup fails.
5. Copy Age of Wonders Shadow Magic content from .wine folder to .cedega (both in your home directory.
6. Adding dpnet.dll to your windows/system32 by touch-ing it will create a blank file.
THX to Mr. Fischer for the 1st steps....

7. Download http://www.thehandofagony.com/alex/dll/dplaydlls-win98se.tar.bz2
And extract it into windows/system32/ of the cedega aowsm

8. Now edit the IP-Address entry of your local host (mine was 127.0.1.1 MyLaptop) in /etc/hosts to your correct IP for LAN / Internet game.

9. HAVE FUN

Single Scenario is playable but not sooooo good in full screen, try some setup/gfx tweaks - Windowmode is fine. Taking part in LAN or Internet game works perfect on fullscreen.

Perhaps all the tweaks will also work without cedega only on wine... never tried it, only the described one.

THX to all great HowTo's on the Net helping me to get this thing run.

[This message has been edited by getflashed (edited 04-10-2007 @ 04:28 AM).]

posted 10-06-07 08:48 AM EDT (US)     42 / 54  
Well.... Internet games seem to work fine with cedega, but it looks like I can't Host a new game.
posted 11-10-07 03:10 PM EDT (US)     43 / 54  
AoW SM runs great on my system using Wine 0.9.4X. It installs and runs correctly without any additional tricks. The only problem is that I can not get any of the network things to work. Neither the Lan game or Internet game buttons do anything when I press them. I have installed the directplay dlls and created the dll overrides in wineconfig. I have changed my hosts file so it has this in it:

192.168.0.102 myhostname
127.0.0.1localhost

I can ping both addresses by IP or by name.


AoWSM is really the only reason I still have to keep Windows XP around, I need to play lan games regularly.

I had the same results when I tried to play under Cedega, so I'm suspecting I may be doing something wrong with the hosts file.

If anyone has suggestions, please post a followup.

Thanks!
posted 11-22-07 01:17 AM EDT (US)     44 / 54  
Hi,

I have made an Howto for playing AoWSM using Linux (Ubuntu 7.10 and wine 0.9.46). I tried to make the howto easy, so I explained every step.

Here is the link:
http://aow2.heavengames.com/downloads/showfile.php?fileid=866

Enjoy,

Martinus VII

By the way: this installation method worked for me, but it is definitely not the only way. So feedback is appreciated.

[This message has been edited by Martinus VII (edited 11-22-2007 @ 01:21 AM).]

posted 01-05-08 04:49 PM EDT (US)     45 / 54  
What about the internet and LAN games?..
Did anyone have any success with it...
I personaly didn't(
posted 04-03-08 03:39 AM EDT (US)     46 / 54  
Hi Guys!

Just an Update!
I have been testing Shadow Magic on Leopard with CrossOver Games. works pretty awesome there is a Bug where your screen is flipped upside down.

You may be able to work around the issue by setting the following registry key:
HKEY_CURRENT_USER/Software/Wine/Direct3D/RenderTargetLockMod e = "readtex"


http://video.google.com/videoplay?docid=1815295149941278927&hl=en


There is a Flickering bug ... which ... I'll look into.

Karl

-------------------------------------
The Magical AOWSM Mac and Linux Howto
http://fischer.org.za/aow/
-------------------------------------
*HOME * SWEET * HOME*
http://fischer.org.za
posted 07-21-08 01:08 PM EDT (US)     47 / 54  
Just installed AoW:SM on Leopard using Crossover Games, and the installation was flawless. However, it doesn't recognize the CD even though it's set up to be visible (and obviously worked during install) -- probably some kind of copy protection? Anything I can do to get it to work?

Thanks in advance,
-Lars
posted 07-21-08 08:32 PM EDT (US)     48 / 54  
@ hobbledehoy

The F4 function key toggles a performance rating number for the frame rate speed.

I have experienced the flickering bug in Shadow Magic many many times. (I use a Windows XP system).

I have noticed that whenever the flickering bug occurs, the frame rate speed slows down dramatically.

After watching your video, I have to say that I usually experience the flickering bug either during a battle or while scrolling across the global map.

Although I haven't experienced the flickering bug during the menu phase, I do experience some difficulties while accessing the save/load/exit menus.

I experienced a nine minute lag in performance to save a game just yesterday. I clicked on the options tab and selected the save option then the game froze for a block of time over seven minutes long before the actual progress bar even came up and then there was yet another block of time over two minutes long just to complete the save.

I wonder why the frame rate speed slows down to a crawl during the flickering bug or why the save/load/exit game functions freeze up and take so long to complete sometimes (but not always)?

Maybe I should try shutting down every unnecessary program before I begin playing; but I am skeptical as to whether doing that would really help to improve anything.

[This message has been edited by flyguy (edited 07-21-2008 @ 08:57 PM).]

posted 07-24-08 00:50 AM EDT (US)     49 / 54  
The correct function key for toggling the frame rate speed is the F9 function key!

I'm sorry that I made the mistake of listing the F4 function key as the frame rate toggle. (F4 toggles the hex grid).

I did notice that the frame rate speed does display on the menu screen.

Maybe you can try to reproduce your flickering bug on the menu screen and see if the frame rate speed is greatly reduced during the flickering process.

[This message has been edited by flyguy (edited 07-24-2008 @ 00:56 AM).]

posted 12-25-08 01:40 PM EDT (US)     50 / 54  
Linux-users who want to play AoW:SM and want to use a modern version of wine (>1.0) with Ubuntu 8.10 can use this howto. I will maybe make a longer howto with exact explanation of every step for linux starters and upload it. The bad news about Ubuntu 8.10 and wine >= 1.0 is that it only works in the "window" mode (At least according to my experiments, "window" mode explained below)). The good news is that you do not need a crack anymore to play the 1.3 or 1.3/1.4 UPatch. You can just use the CDROM.

install AoW:SM with wine
run wine configuration (command: winecfg in terminal) and adjust the sound and graphics values of wine as indicated below. (Maybe you need other configurations with sound for your pc)
run with wine the AoWSMSetup.exe and set the values as indicated below. Especially the display mode must be set to "Window"

Audio tab wine configuration:
ALSA Driver marked
Hardware Acceleration: Emulation
Dafeault Sample Rate: 22050
Default Bits Per Sample: 8
Driver Emulation: not marked

Graphics tab wine configuration:
Windows Settings:
only "Allow the windowmanager to control the windows" marked
other 3 options not marked
Direct3D:
Vertex Shader Support:Hardware
Allow Pixel Shader: marked

AoWSMSetup:
Video:
Display Mode: Window
adapter: DirectDraw HAL
Detail Level: High
Cursors: software
Show Intro: not marked
Allow resolution Switches: not marked
Use Direct3D: marked
Sound:
Direct Sound: not marked, the other 6 checkboxes of sound all marked.
general:
Blood: marked

Now the mouse is still probably not working correctly:
open a text editor and type:

#!/bin/bash
RENICEMEPLEASE ()
{
sleep 2s
for a in `pgrep wineserver`; do renice 19 -p $a; done
}
RENICEMEPLEASE &
wine "C:\Program Files\Age of Wonders Shadow Magic\AoWSM.exe"

you start AoWSM using this script by double clicking it and then run or in the terminal: bash {name you used to save the script}

(without the { and } )

You can install the 1.3/1.4 UPatch with wine and still run from CDROM. In previous versions of wine it appeared to be a problem to completely turn off the sound. With sound enabled these troubles were solved

I will maybe make a step for step guide one of these days for Ubuntu 8.10

feedback is appreciated, as I am no linux guru.
I used information of Karl and others on this forum and also used info at the wine application database entry for AoWSM

Martinus VII

[This message has been edited by Martinus VII (edited 12-25-2008 @ 01:55 PM).]

posted 09-17-10 03:40 PM EDT (US)     51 / 54  
I've been able to run the recently to-be-released Impulse version of AoW:SM on my iMac via a Parallels Desktop 5 VM going to a BootCamp partition. Various combinations of settings in the config editor have crashed the game (in particular, when I tried running it at full 2560x1440 some text got garbled on the "start campaign" screen and the game nearly took my VM down completely). Still messing with the settings - unchecking "d2d" and "switch resolution" seem to be required, but I've been able to run successfully in 1280x1024 resolution.

EDIT: as something of a correction to that, I've found tht performance in Parallels is abysmally slow (I'm guessing it has something to do with the Parallels video drivers). Rebooting into Windows works file though. I'm probably going to upgrade to Parallels 6 soon, and I'll report back about how well that works.

[This message has been edited by thither (edited 09-18-2010 @ 01:07 AM).]

posted 12-28-10 09:59 AM EDT (US)     52 / 54  
I have tried to run this game under wine in puppy linux, the game gets started but mouse-click is not working.
I can move mouse around but I can not click anything in the screen, so I am stuck with first screen.

(I have followed the instructions and tried some modifications...)
posted 04-06-12 07:54 AM EDT (US)     53 / 54  
Have you tried installing it through PlayOnLinux?

http://www.playonlinux.com/en/

They have a script that will do all the messy work. This has worked for me.
posted 08-21-12 05:28 AM EDT (US)     54 / 54  
Game works great so far using GOG version with Wine on Ubuntu 12 just having trouble patching it to 1.3 or 1.4. Whenever I enter the directory on the C: drive it says it can't find AOWSM executable. Any ideas?
« Previous Page  1 2  Next Page »
Age of Wonders 2 Heaven » Forums » AoW:SM Tech Help & Bug Reporting » AoW, AoW2 and AoW:SM on Linux and OS X
Top
You must be logged in to post messages.
Please login or register
Hop to:    
Age of Wonders 2 Heaven | HeavenGames