You must be logged in to post messages.
Please login or register

AoW:SM Tech Help & Bug Reporting
Moderated by Swolte, Ziggurat Mason

Hop to:    
loginhomeregisterhelprules
Bottom
Topic Subject: Random crashes and Video problems
« Previous Page  1 2 3  Next Page »
posted 07-28-03 04:20 AM EDT (US)   
Just a reminder that lockups, random crashes, and corrupted graphics are often caused by bugs in video drivers. When encountering problems in aowSM (or any game), players should check for newer drivers, DirectX versions, etc.

In the case of Nvidia cards, some users have reported better results with the older 41.09 drivers than with newer ones, so users experiencing problems in aowSM may wish to try those drivers as well.

Using aowSetup to disable Direct3D, DirectSound, and/or Resolution Switching may also correct problems, and changing your desktop to 16-bit color has worked for a few people as well.

Replies:
posted 07-28-03 05:27 AM EDT (US)     1 / 73  

Below is something I wrote from an older topic...:

For those that are having problems... here's some helpful hints regarding what may fix your issue:

1) Update the drivers for your devices... especially your graphics & sound card.
2) Turn off or uninstall any anti-virus software
3) Uninstall the game, reboot computer, reinstall the game into a different location
4) Turn off any applications running in the background... this includes the small icons on the bottom right near the time.
5) Turn off unnecessary 3rd party services... if you don't know where to find these then call Microsoft. They will also help you "clean boot" the system for better performance. Do not turn off Microsoft services... Microsoft services almost always have a description, 3rd party services rarely have descriptions.
6) Sacrifice your neighbors cat to Josh and Wazz on top of your car to show appreciation for the AOW2:SM game! {just teasin}
7) Reinstall DirectX 9.0a the new DirectX 9.0b may not work... but you may consider trying this too.


There can be only one.
Highlander
posted 07-30-03 02:14 PM EDT (US)     2 / 73  
>> 2) Turn off or uninstall any anti-virus software <<

I would NEVER recommend uninstalling anti-virus software, no game is worth leaving your computer vunerable to trojans, worms, etc. Even disabling anti-virus software is a bad idea unless your positive that you will remember to turn it back on before you check or open email. While I understand many players do this to increase system performance, the reality of the situation is that except for very old systems (like P100 or under) the anti-virus check impacts program performance in a very small way, certainly nothing that a single user show worry about. If you play online shooters where a couple of fps can make a difference and your a smart computer operator - it might be worth the risk. But not for AoW:SM, at least IMO.

Okay I'm off my soapbox on this issue...

[This message has been edited by nitey (edited 07-30-2003 @ 02:15 PM).]

posted 08-01-03 02:29 PM EDT (US)     3 / 73  
nitey, please don't post about anti-virus software; you are giving people incorrect information. Anti-virus software is notorious for not only slowing down access to files, but also to making the whole system less stable. Anti-virus software is very good in general, but the auto-protect options will slow down even a high-end system. Just try playing a first-person shooter with antivirus software running, even on a high-end system, and watch that framerate drop...

EDIT: Just to clarify, I mean drop as in 60fps to 30fps, not just a small drop of a couple frames here and there. Even games like Civ 3 will run much slower with AV software running.

I agree with NTJedi; disabling the constant scan of antivirus software is very important for gamers. AV software is just too resource dependant.

[This message has been edited by brody76 (edited 08-01-2003 @ 02:30 PM).]

posted 08-03-03 01:00 AM EDT (US)     4 / 73  

Hi Josh,

I was playing a random map and got a crash to my desktop. This is the first time it has crashed for me. Below are my system specs and the error generated by the crash. Let me know if you would like a copy of the auto-save game file.

Best Regards,

Raven Bear


Operating System: Microsoft Windows XP (5.12600)
DirectX Version: 9.0 (4.09.00.0901)
Desktop Resolution: 1024x768x16
Physical Memory: 387 / 767 MB
Virtual Memory: 1657 / 2047 MB
Winsock 2 Detected: YES

AoWSM Version: 1.00
Resources ID: 0
Display Resolution: 1024x768x16
Display Mode: Full Screen
Pixel Format: 5-6-5
3D Renderer: Hardware
Display Driver: RADEON 7000 Series (ati2dvag.dll)
Driver Version: 0.0.0.0 (4098 / 20825)

Detail Level: High
Cursor Mode: Software
Sound: On
Music: Off
DirectSound: On

Map: Oc'Ram.asg
Day: 66
Play Mode: Classic
Connection Type: Local
Players: 9
Human Players: 1
Seated Player: 1
Current Player: 3

Combat: Auto Sim
Location: 69,114,0
Players: 2
Current Player: 0

Application opened at: 12:08:01 AM
COMBAT FAILURE: Access violation at address 004B7A58 in module 'AoWSM.exe'. Read of address 00000010
Application closed at: 1:41:30 AM (1 errors)


Raven Bear
New Brunswick, Canada
posted 08-03-03 02:44 AM EDT (US)     5 / 73  
If the loading the savegame reproduces the crash, send it on in... btw, if there's a named error, it's not a random crash.
posted 08-08-03 11:28 AM EDT (US)     6 / 73  
Heeeelp!

I do have the nvidia card, and the latest driver causes it to crash before loading the game (just after the 'online play esrb' message). Turned off the resolution changing option, as well as all other hints (16M colors, etc).

The older driver does work. Unforunately, it makes my other games cruddy (Mechwarrior Mercenaries runs horrid, but great on the newer driver).

Is this an issue that will be resolved in a patch? And ETA on a patch? It's a bummer I can't use the lastest drivers, or have to unload and reload drivers to make all my games run well. *sigh*

FleabitFox

posted 08-08-03 03:13 PM EDT (US)     7 / 73  
We cannot fix bugs in video drivers. AowSM is making perfectly valid DirectX calls, as shown by the fact that other driver revisions work perfectly, and other video cards as well. Nvidia is the only one who can make their drivers behave properly. We cannot reprogram the entire game every time a video card manufacturer decides to break a required DirectX feature.
posted 08-08-03 03:21 PM EDT (US)     8 / 73  
use nvidias 2X.XX drivers for your GeForce 2 cards
3X.XX drivers for your GeForce 3 cards (30.83 I believe is what people loved)
4X.XX for your GeForce 4 cards. I loved 41.09 when I had a GF4 Ti4200

It seems that whenever nVidia makes a new card they leave the older cards in the dust. It's a business like any other though. Their newest drivers are geared towards the FX line of cards. I'm noticing a lot of the older users have problems with the new drivers. WHY? nVidia "optimizes" them to make the FX line seem faster.

For ATI cards all the Catalyst versions run fine with AOW.
Although I found V3.5 & V3.6 have a small problem with AOW2 and AOW:SM. If you alt-tab, then go back in the game you might find the screen/image has been corrupted. As usual I made ATI aware of this. Since I was the only one to mention it, I doubt they'll take a look at it. (probably because I'm the only one who actually played AOW and not some First person shooter game)
http://www.dodstudios.net/uploads/uploads/CatalystAOWcorruption.jpg

[This message has been edited by Leprechaun (edited 08-08-2003 @ 03:27 PM).]

posted 08-08-03 07:00 PM EDT (US)     9 / 73  
Hey, thanks for the response, it's appreciated!

It's a pity it doesn't work right, but I do believe you. It works with all my other games, which is more than a few, it just doesn't work with Age of Wonders Shadow.. gah. Mechwarrior is completely unplayable with the older driver, works awesome with the new one. I guess I'll have to keep unloading and reloading old and newer drivers when I want to play one or the other.

Oh well, worth the effort.

FleabitFox

posted 08-29-03 08:27 AM EDT (US)     10 / 73  
a bios update fixed my problem of the game crashing after 5 minutes of play; I believe the crashes were due to something in the unholy trinity of my nvidia4400, its drivers, and directx9--somewhere my 4400 or its drivers weren't gelling with directx9 and my old bios

my system has an asus p4pe mobo, corsair ram, a west. dig. hd, winxp pro, and 2.4 p4

I realize a bios upgrade may be a big deal for some, but I tried all the other recommended solutions (one at a time to try to isolate the problem/solution) and even did a clean install of winxp all to no avail--but after all that a 5-minute bios upgrade took care of business....

posted 09-05-03 04:53 AM EDT (US)     11 / 73  
I repost here conclusions of another thread of mine : as for Nvidia drivers, it looks like only 44.xx versions are not compatible with SM in D3D mode.

I confirm that 43.45 DOES work on my W98SE system with an old GF2 MX.
41.09 worked too but caused random freezes at boot on my system...
Some posted that the new 45.23 also worked, with FX cards and unspecified OS.

posted 09-05-03 11:24 AM EDT (US)     12 / 73  
leaptoad,

My system is also an ASUS. Things that make you go hmmmm.

Did you download BIOS? Or did you have to go buy it? Where did you get the upgrade?

It's really annoying not to be able to even start windows from the windows CD and to have the Western Digital utility say your hard drives are in perfect working order.

Downloaded Norton Antivirus, and it detected possible boot problems with windows system files in its initial scan and haven't been able to even get windows to boot ever since.

Hating it.

posted 09-07-03 02:15 PM EDT (US)     13 / 73  
SurvivalistMerch: I think you have two problems here: 1) win xp isn't loading up and 2) you'd like to upgrade your asus mobo's bios

prob 1): this solution may work but *only* DO IT IF YOU DON'T MIND PERMANENTLY WIPING ALL DATA FROM YOUR HARD DRIVE

step a: make a restart disk from a windows 98 machine, step b: start your xp box with this disk, then use the "fdisk" command to delete the current partition(s), then create a new partition,
step c: use the "format c:" command to format the new, spankin'-clean partition on your harddrive,
step d: now restart with your win xp disk (make sure the bios is set to boot from a cd drive)

prob 2): upgrading your bios is "free" in the sense that you don't pay money to upgrade it--unless things go wrong and you permanently screw your mobo and need to buy another

step a: find your mobo's chipset at http://www.asus.com/products/mb/mbindex.htm
it's very important to get the right chipset!
step b: go to the "downloads" section of your mobo and find the most recent bios version (for example mine was "P4PE BIOS 1006"
step c: click the little download bios disk icon
step d: *VERY IMPORTANT* do not download your bios upgrade yet, instead, click on the "BIOS Update Step" link
step e: follow the "Motherboard BIOS Update Procedure (For P2/P3/P4 and Duron/Athlon Motherboard)" link
step f: I reccomend printing out this whole page (this page also has a link to download the bios flash utility) and reading it several times--essentially you're going to make two bootable disks for win xp; on one bootable floppy you'll have the bios flash program by itself--the rest of the space on this first floopy will be to back up your current bios; on the second bootable disk you'll have the bios flash program and the new version of bios--you'll use this disk after you make a back-up copy on your first disk--WARNING--if your power goes out during a bios upgrade, your mobo may need some serious repairs
step g: now that you've read the directions and have two bootable disks with the flash utility, go back to the downloads page and get the most recent bios version and go for it

of course, I only recommend upgrading your bios after you have a working copy of win xp *and* have exhausted your other alternatives for getting shadow magic to be stable--the only reason I mentioned my bios upgrade success is because I had tried all the other alternatives to no avail; because I had tried each "fix" one at a time and then tested my shadow magic stability, I was able to determine that it was only the new bios that had made a difference

ps: i'm using the nvidia 4.4.0.3 drivers and directx 9b

posted 09-10-03 10:09 AM EDT (US)     14 / 73  
Has canybody noticed a slower performance when Directx 9 installed, compared to Directx 8 ?

I have seen users of a different game post this, so I wonder ...

posted 09-10-03 11:49 AM EDT (US)     15 / 73  
Hi,

greetings to everyone, this is my first post.

If it comes to slower performance I found during TC that sometimes the game slows down drastically. The Animation and reactiom on my commands are extremely slow. It last for 1 to 3 minutes and then everything is all right again. I can live with it but that's very annoying.

posted 10-03-03 08:38 PM EDT (US)     16 / 73  
I have the same Problem: Slowdown -> Unplayable ! I have the new driver and DirectX and it is horrible in the battle!

Card: AOpen Aeolus TI 4200

posted 10-09-03 06:17 PM EDT (US)     17 / 73  
What version of DirectX do you have ? Do you have NVidia cards ? There were hints in the past (outside of this Forum, for example posted in a german magazine) that NVidia cards might have huge performance problems with DirectX 9.
posted 10-13-03 04:48 AM EDT (US)     18 / 73  
I use DirectX 9 and a Aeolus TI4200. When this is the problem, then I can nothing just waiting for the next Direct X or the next driver. I can disable Direct 3D for better performance, but then some grafic-Effects in the spells are missing like holy light.
posted 11-18-03 12:24 PM EDT (US)     19 / 73  
Im having problems when I switch resolutions in AOW SM. The grafix becomes corrupted.

I have the newest driver for my videocard Radeon 9700 PRO.

Any help would be excellent, thx.

posted 11-19-03 09:59 AM EDT (US)     20 / 73  
I've noticed that when direct3d is not ticked in aowsetup.exe, area of affect indicators no longer show up when in TC. Such as where a bombarder, or lightning catcher will hit, where a flamer or frost blower will hit and also with things such as round attack (nothing is there, no red line indicators). Spells area affects are also no longer shown.

Is this a bug? Because when I was using version 1.1 is wasn't a problem even with direct3d not ticked but now that I'm using v 1.2 it is a problem, whats going on here???

posted 01-03-04 06:16 AM EDT (US)     21 / 73  
Anyone experiencing difficulties with the Nvidia 5900 besides me? I don't think 44 drivers will work on this nor should I think that is the ideal fix anyway. Not sure I agree with Josh in his earlier statement about the video manufacturers as it's only in their best interest too to make direct x compatible drivers.
posted 01-28-04 00:06 AM EDT (US)     22 / 73  
Here's an annoying little problem that occurs regarding the video.

Many times during large battles I like to hit f5 to reduce that game to a window and do other things. Sometimes, not all the time, when you hit f7 to continue the game, the entire map screen is black with the exception that you can see domains. The mini map appears as usual, but you are not able to see anything in the world view map. If you hit f5 again, you can play in the window.

I've noticed that in order to correct the problem, you can hit f7 during the next battle, after which you can see again in full screen mode.

The annoyance of this is that it is very difficult to scroll in the window mode, as you can not just move your mouse to the edge of the screen and you must control what is seen in the world view by dragging the box in the minimap.

This is not a game stopper, but I've found myself explaining what to do to others during games, so I know that I'm not the only one having these problems.

Probably too late to make it into the patch, but thought I'd put it up anyways.


Tom Bombadil

"And even in a mythical Age there must be some enigmas, as there always are. Tom Bombadil is one (intentionally)."
The Letters of J.R.R. Tolkien, No 144, dated 1954

posted 02-01-04 04:49 AM EDT (US)     23 / 73  
tom, you can scroll with the arrow-keys

Golem aka Gol'fleme on gamespy. Author of the GolMod
posted 08-22-04 06:54 PM EDT (US)     24 / 73  
I have the same problem. I uninstalled en reinstalled the game again with the (new) v1.3 patch and have got the bug since.

My stupidity by far outclasses yours!
posted 01-31-06 00:14 AM EDT (US)     25 / 73  
Here is a videoish random crashy problem I ran into, and a fix for it.

Problem: Game doesn't start. The screen resizes to play the intro video, and occasionally you can hear the first few notes of the intro, but it crashes before displaying anything.

Fix: Right clicky "AoWSM.exe" > Properties. Go to the Compatibility tab, select "Run this program in compatibility mode for: Windows 98/Windows ME.

Attempting to fix: First, I loaded the standalone Bink player, and verified I could play the *.bik movie files. Then I disabled the intro video. The game would load, but that's just not good enough for me, and there were other video files in the movie directory... which worried me a bit. I tried all the other options in setup. So, I patched. Then I tried a different binkw32.dll (Shadow Magic has 1.5.20.0, turns out Rag Doll Kung-Fu has version 1.8) Didn't help. Tried some other .. uh.. executables that may exist and I shan't discuss. No luck. Then remembered how damn old the game is. And compatibility mode is my friend.

Operating System: Microsoft Windows XP (5.12600)
DirectX Version: 9.0 (4.09.00.0904)
Desktop Resolution: 1152x864x16
Physical Memory: 1503 / 2046 MB ; Virtual Memory: 1721 / 2047 MB
Winsock 2 Detected: YES

AoWSM Version: 1.30 ; Resources ID: 0
Display Resolution: 1152x864x16 ; Display Mode: Full Screen
Pixel Format: 5-6-5 ; 3D Renderer: Hardware
Display Driver: RADEON X850 XT (ati2dvag.dll)
Driver Version: 0.0.0.0 (4098 / 23890) CAT 6.1

Detail Level:High ; Cursor Mode:Software
Sound: On ; Music: On
DirectSound: On

posted 02-10-06 01:15 PM EDT (US)     26 / 73  
I've been having trouble with this game and my new computer ever since I got the new computer.

It's really strange I can get the game to not crash during gameplay with some of the suggestiosn in this thread but when I exit the game I get the blue screen of death, everytime.

I'm running
Windows XP sp2
2 gigs of ram
Nvidia Geforce 6800 BIOS 5.41.02.34.05
When I play I put the computer in to 16bit color mode

Game settings:
Display Mode:1024x768 (also my normal display mode for my computer)
Adapter: NVIDIA GeForce 6
Detail Level: High
Cursors: Software
Checked: Show Intro
Checked: Allow Resolution Switches
Unchecked: Use Direct 3D
Sound: Everything checked but Direct Sound
I also have the 1.4 patch installed

Oh and windows tells me it's an "Error caused by a device driver" but doesn't know what driver and such.

Can anyone help? I've been having a heck of a hankering to play but I don't want to kill my computer.

posted 04-29-07 11:19 AM EDT (US)     27 / 73  
This is for the original age of wonders game (not shadow magic). Turns out that the graphics accellaration was causing the game to crash on xp. worked fine on windows 98 and 95, and I had no problems with age of wonders II. So right click on window, then click on settings, then click on the advanced button. Then click on the Trouble shoot tab, then just click down the hardware accellaration to a point where DirectX is enabled - but just barely. Then hit apply. now the game seems to work much better.
posted 05-21-07 03:18 AM EDT (US)     28 / 73  
I had been playing AoW:SM under XP SP2 using one of the newer GeForce-cards and I only got it to work by lowering the hardware acceleration setting in the compatiblity window (I hope you know what I mean, I am in a hurry right now, so I can't explain).
Now I got rid of all crashes, but my solution won't make everyone happy: I installed Vista. I haven't had any serious crashes since. With XP the game crashed about once every hour, now it has crashed maybe two times in the weeks I am playing it now. And those crashes were just clean BTDs, not bluescreens that would reboot the computer.

Just my two cents.

[This message has been edited by kokemohr (edited 05-21-2007 @ 10:16 AM).]

posted 11-01-07 10:44 PM EDT (US)     29 / 73  
Hi! I am having problems loading a game that was saved a couple of days ago, and was running last week with no problems. Basically it gets 3/4 of the way loaded and then freezes up - very strange. I can move the cursor around, so I can click on Quit to drop out of the game, but even waiting for 15 minutes or so doesn't make the game load.

I have had other assorted problems that video drivers and setup settings have fixed, but none of those seem to work for this one. I just reinstalled the game to fix some other problems, and updated to 1.4..., and started this new game last week after all of the updates.

Here is my info:

Operating System: Microsoft Windows XP (5.12600)
DirectX Version: 9.0 (4.09.00.0904)
Desktop Resolution: 1024x768x32
Physical Memory: 596 / 1023 MB
Virtual Memory: 1898 / 2047 MB
Winsock 2 Detected: YES

AoWSM Version: 1.20
Resources ID: 0
Display Resolution: 800x600x16
Display Mode: Windowed
3D Renderer: Software
Display Driver: NVIDIA GeForce 6200 TurboCache(TM) (nv4_disp.dll)
Driver Version: 0.0.0.0 (4318 / 353)

Detail Level: Low
Cursor Mode: Black & White
Sound: On
Music: On
DirectSound: Off

Map: FamilyFeud v3.asg
Day: 49
Play Mode: Classic
Connection Type: Local
Players: 9
Human Players: 2
Seated Player: -1
Current Player: 8

Combat: None

Application opened at: 7:35:50 PM
Access violation at address 004C49F6 in module 'AoWSM.exe'. Read of address 00000038
Application closed at: 7:36:13 PM (1 errors)

Thanks for the help!
posted 11-02-07 09:39 PM EDT (US)     30 / 73  
Trouble loading a saved game might mean that your save file was corrupted. One way to get a corrupt file is to start saving the game while one of your units is still moving. There may be other ways to corrupt your save game like maybe if the AI was moving a unit when you clicked save or something like that.

It may be possible that your auto-save file is still good.

Good luck.

[This message has been edited by flyguy (edited 11-02-2007 @ 09:40 PM).]

« Previous Page  1 2 3  Next Page »
Age of Wonders 2 Heaven » Forums » AoW:SM Tech Help & Bug Reporting » Random crashes and Video problems
Top
You must be logged in to post messages.
Please login or register
Hop to:    
Age of Wonders 2 Heaven | HeavenGames