You must be logged in to post messages.
Please login or register

AoW2 Technical Help
Moderated by Swolte, Ziggurat Mason

Hop to:    
Topic Subject: Lan gaming
« Previous Page  1 2  Next Page »
posted 03-30-03 09:20 AM EDT (US)   
For some reason this game just won't work over my lan. I don't have any problems with my other games. BGII, red alert, MW3, MW4 and so on.

This particular game just doesn't seem to recognize the other computer when you try to join a lan game. I've tried hosting from both machines. I've tried waiting a really long time to see if it would finally pick up. In desperation I've even tried different ports on my hub . I am going to try installing VPN on both machines and see if that works for god only knows what reason.

I don't know what else to do. It seems to work ok over the internet, but I can't connect via the internet to another machine on my lan and I really want to play with my GF.

I have all of the networking protocals installed, netbeui, tcp/ip and of course IPX/SPX. My machine has a 1.8 gig processor 256 megs of ram, 64 meg vid card, one of the SBlive sound cards, realtek network card.

More Lan stuff.
Client for Microsoft Networks as primary login
service is of course file and printer sharing.

So what gives?

posted 03-30-03 09:38 AM EDT (US)     1 / 54  
How do you mean connect via Internet to your GF's computer? Aren't you both on the same LAN?

Btw, do you have DirectX 9? It fixes some earlier problems with DirectPlay, which is used by AoW2.

posted 03-30-03 10:27 AM EDT (US)     2 / 54  
Yup. I've had DX9 for quite some time. Also, installing VPN didn't help. I also went ahead and re-installed the game and the patch on both of my machines. Still no go.

As for connecting to a machine on my lan from the internet that should theoretically be possible. I just bounce my packets off my ISP's server with tcp/ip instead of through my lan with ipx/spx. Er wait.

She has a different IP than i do on my lan. That's normal right? I swear I've never had any problems with any game before with this configuration.

posted 03-30-03 10:54 AM EDT (US)     3 / 54  
I switched off uplink on my hub. Shutting me off from the internet. Checked IPconfig to make sure we were both just using PPP and tried loading up the game and still got no where. There's no games listed....
posted 03-30-03 11:10 AM EDT (US)     4 / 54  
What operating system do you have?
Are all firewalls disabled?
Have you tried to find the computer in the windows explorer?
Are you in the same subnet mask and/or work group? (Shouldn't matter, but does sometimes...)

Chaos is ever-present, unavoidable, even necessary. Chaos is the way of time, the way of nature, the way of unthinking animals. Chaos will happen. But sentient, thinking beings do not need to help it along. Law is the effort of the civilized to slow chaos, to keep destruction at bay long enough so that thinking, dreaming, hoping, and loving can occur.

[This message has been edited by greywind (edited 03-30-2003 @ 11:12 AM).]

posted 03-30-03 11:16 AM EDT (US)     5 / 54  
And you do use the LAN feature, not the Internet one, right?
posted 03-30-03 11:18 AM EDT (US)     6 / 54  
I can see the computer in network neighborhood and can access files from the shared directory from both machines
firewall is off and both machines are in the same workgroup and subnet. Thanks for the suggestions man. Keep um coming. Still no go.

Oh yeah, one more weird thing. The game works over the internet with one of my friends in boston. So MP isn't a total failure. Just failing for what I originally bought the game for.

posted 03-30-03 11:19 AM EDT (US)     7 / 54  
Yeah, I use the lan feature when I went to play with my home pc's, and internet the one time that I wanted to play my friend in boston
posted 03-30-03 11:22 AM EDT (US)     8 / 54  
Hmmm. You do have the same version of AoW2, have you?

Chaos is ever-present, unavoidable, even necessary. Chaos is the way of time, the way of nature, the way of unthinking animals. Chaos will happen. But sentient, thinking beings do not need to help it along. Law is the effort of the civilized to slow chaos, to keep destruction at bay long enough so that thinking, dreaming, hoping, and loving can occur.
posted 03-30-03 11:22 AM EDT (US)     9 / 54  
Hmmm... Does the other computer use Win98 as well?
posted 03-30-03 11:46 AM EDT (US)     10 / 54  
Both machines are running windows 98 SE, and AoW 1.02. Thanks for continueing to suggest things guys. Please keep them coming.
posted 03-30-03 11:52 AM EDT (US)     11 / 54  
Could you describe your network a little? Hubs, routers, firewalls etc.
posted 03-30-03 12:25 PM EDT (US)     12 / 54  
Well, the network is pretty simple. It's two pc's running win98 SE networked through a netgear hub. The cable modem goes into the uplink on the hub, both PC's have inet access and can see each other when logged in. The main PC runs tiny personal firewall, but I have it disabled in Msconfig now while I'm working on the lan play for this game. I did try uninstalling the firewall as well. That didn't work.

I have a request for some odd information. There is a directplay registry key in the registry. I noticed that during one of my installs a key for AoW was put under there and then on subsequent installs it hasn't been there. I'm not sure what that means. If somebody who's running win98 could do a search through their registry and give me the keys it makes I would be very grateful. Just search for age of wonders. That should do it.

Also, please keep the suggestions coming. Im tearing my hair out over here.

posted 03-30-03 02:07 PM EDT (US)     13 / 54  
You might try the Internet button in aow2, since each machine has a distinct IP address. Both the Internet and LAN buttons use TCP to connect, btw.
posted 03-30-03 02:16 PM EDT (US)     14 / 54  
Heh, I tried that one along time ago. Kind of mentioned it in my original post. But thanks anyway. Please keep the suggestions coming. This is the weirdest thing I've ever seen. Lan gaming is really pretty straight forward. Although I think most of the games I play on regular lans use IPX/SPX, how come this one uses TCP/IP?

Could this have something to do with my issue? I can game on the internet with this product. I can access the internet from both computers on the lan with no problems. I just can't play on the lan with this game..

posted 03-30-03 02:20 PM EDT (US)     15 / 54  
I really think that DirectPlay is the issue, since you can play other games and share files. In that case there's not much you can do, except reconfigure your network....

I have two computers connected with a cross-connect cable, and a cable modem connected to one of the computers (which has two Network cards). I then use ICS to share the modem connection to the other computer. I can play both LAN and Internet games with that configuration.

posted 03-30-03 02:54 PM EDT (US)     16 / 54  
Reconfigure my network? Im not sure what you mean. Are you suggesting that I go and buy a null modem cable? Is that what you mean by cross connect cable? Direct serial? I wish I could do that but the distance between the two machines is pretty great. The only other thing I can think of is getting a router.. Sigh this sucks.

Did anybody with win98 search for those keys I mentioned? The reg keys under directplay in the registry?

posted 03-30-03 03:12 PM EDT (US)     17 / 54  
Ok, I thought your comps were next to each other.... (A cross connect cable is a TP cable that allows you to connect two computers with their network cards without using routers, hubs etc.)
posted 03-30-03 03:57 PM EDT (US)     18 / 54  
TCP/IP is a much faster and more reliable protocal than IPX is. Newer operating systems can also have problems with it, like XP.

Anyway...when you try to play, you type in the IP address of the other computer, and it doesn't find any games, right? Are you completely sure it isn't a LAN IP address instead of an internet IP address? A LAN IP address is only going to be recognized by computers on the same network, not over the internet.

And of course, you could always try to play over GameSpy.

posted 03-30-03 03:59 PM EDT (US)     19 / 54  
Hmmmm... I guess I could give that a try. I hope there are other suggestions coming though. It's not that I'm cheap, it's more that I'm to lazy to go outside unless my chair is on fire.

So you think the problem is my hub?

posted 03-30-03 04:05 PM EDT (US)     20 / 54  


So you think the problem is my hub?

Maybe, it's worth to try without it and see what happens.
posted 03-30-03 05:05 PM EDT (US)     21 / 54  
Well, I just tried updating the drivers for my nic and the nic on the other PC. They were both really out of date, but updating them didn't fix the issue. Im gonna try to the twisted cable ethernet configuration soon, but I would still appreciate more ideas. MP with my GF on our lan is the reason I bought this game and it's not working......
posted 03-31-03 12:19 PM EDT (US)     22 / 54  
Welp. I tried the cable you mentioned. No hub, just my pc going into another pc. Still no lan game detected when either machine hosts....
posted 03-31-03 01:28 PM EDT (US)     23 / 54  
Can you transfer files in Windows?
posted 03-31-03 04:23 PM EDT (US)     24 / 54  
Windows 98 File and Printer Sharing is handled by NetBIOS and by default carried on the NetBEUI protocol. This is separate and independent of the TCP/IP protocol used by AoW2, and the ability to see other computers in Network Neighborhood and/or share files with them does not necessarily imply TCP/IP connectivity. Note also that you may both be able to access the iNet by routing through a gateway, without being on the same local IP subnet.

A more important test is to see whether you can Ping each computer from the other. To do this you will want to know the local IP address of each machine. This may be manually assigned in the bindings for 'Network' > 'Properties' > 'TCP/IP -> [your Lan adapter]' > Properties if "Specify IP Address" is checked, or if not assigned dynamically by your router or connection sharing software (this is the default).

can check this with IPCONFIG from the command prompt, both machines should normally have an IP in one of the reserved ranges, most often in the subnet, where xxx should be the same for both machine (usually 0) and yyy must be different. The subnet mask should be unless you have a particular need to make it something else.

Obtain both IP addresses, then type the command

PING {ip address of other machine} and see if you recieve a response, and let us know what you get.

[This message has been edited by ChowGuy (edited 03-31-2003 @ 04:42 PM).]

posted 03-31-03 08:04 PM EDT (US)     25 / 54  
Wow... It doesn't ping. I can't ping the other machine. So I guess tcp/ip isn't working over my network, that explains why mp works over the internet but not at home. Damn.. What can I do to fix this?
posted 03-31-03 08:08 PM EDT (US)     26 / 54  
I seem to be having another problem. When I go to winipcfg, both of my machines are defaulting to the PPP adapter. Which shows no IP address at all. Just I can switch it with the dropdown to my nic adapter on both machines and then try to ping but get no response. Then when I close winipcfg and come back to it again, it's back on PPP..
posted 03-31-03 08:11 PM EDT (US)     27 / 54  
I'm set to obtain address automatically btw.
posted 03-31-03 09:28 PM EDT (US)     28 / 54  
> I'm set to obtain address automatically btw.

Which is the default during a Windoze installation. Unfortunately for you, that doesn't work unless you have a DHCP server in your network. Some Connection Sharing software can provide this service, but from your replies elsewhere it sounds like each machine has it's own dial-up line (the PPP adapter) rather then a shared connection. This adapter can obtain a dynamic IP from your service provider when a connection is made but that IP will not be visible on the LAN.

To get TCP/IP connectivity on your LAN then, you'll need to manually set an IP addrees on each machine. Assuming Win98:

For Win 9x/ME:

For each machine, right Click on Network Neighborhood and select Properties from the context menu.

In the dialog box that comes up, You should see among other things, two lines like "TCP -> Dial-up Adapter" and "TCP/IP -> 3Com Etherlink ... NIC" (Your actual Network card may be different). Select/highlight the one that refers to your network card, then click on the "Properties" button.

Change the Radio button selection from "Obtain an IP address automatically" to "Specify an IP address" then in the two lines below enter an IP address in the 192.168 reserved range. Most people use something like, 192,168.0.2, etc. Set the Subnet mask to on both machines.

You should not need to change any settings on the remaining tabs for your simple setup. Do NOT change the IP settings for the TCP/IP -> Dial-up adapter - this needs to remain as it is or you will likely lose your internet connection.

Select OK, and OK again. Windows will tell you it's updating, and possibly ask if you wish to keep/replace some files. In most cases you probably will.

When it's finished, re-boot both machines.

For Win2K or Win XP the procedure is slightly different

Right click on the Network Neighborhood Icon, then select Properties.

In the folder view that comes up, locate and right click on the "Local Area Network Connection" icon and select Properties for it. This brings up a dialog box which includes the line "Internet protocol (TCP/IP)" - highligth that line and click on properties, then proceed as above to set the IP address.

Hope this works for you.

posted 03-31-03 09:32 PM EDT (US)     29 / 54  
Well. I've done alot of reading. Let me see if I can explain this. My lan goes from the cable modem into the uplink port on the hub which is port 4. Port 1 goes into PC 1, Port 2 goes into PC 2. They don't ping and I've since learned that one of these machines has to become a client in order for TCP/IP to work. I set the IP address on the client machine to 192.168.0.X. I set the subnet mask to the same number that PC1 uses. PC 2's gateway has changed to WIN resolution is off and DNS is off on both machines.

Assumption 1. Gateway has to be within a certain range of the IP address? For instance, for PC 2. For PC 1 the IP Address is the one specified by the cable modem provider. It's gateway is also within the same range as the IP address. Coincidence or law of networking?

In this configuration. PC 1 can see PC 2 in network neighbor. But cannot ping. It can access INET. PC2 can see PC1 in network neighborhood but cannot access inet.

I think I'm getting close but something is still missing.... Do I have to change something else on PC1?

posted 03-31-03 09:34 PM EDT (US)     30 / 54  
Oh, I'm not using dial up.
« Previous Page  1 2  Next Page »
Age of Wonders 2 Heaven » Forums » AoW2 Technical Help » Lan gaming
You must be logged in to post messages.
Please login or register
Hop to:    
Age of Wonders 2 Heaven | HeavenGames