You must be logged in to post messages.
Please login or register

AoW1 Technical Help
Moderated by Enginerd, Ziggurat Mason

Hop to:    
loginhomeregisterhelprules
Bottom
Topic Subject: Win7 Pro x64 and MapViewer.ShowScene errors.
posted 10-24-15 01:26 PM EDT (US)   
Got a strange error that keeps popping up and killing the game after and hour or two of play.

"Exception in MapViewer.ShowScene"

This is happening in both the Retail CD / GOG version.

Things that I have tried ...

Changing DEP settings and exceptions.
Compatibility layers ( a.k.a. WinXP SP2 / SP3 ).
Multiple uninstalls and re-installs.

Additional tests :

Found a suggestion that the NoExecuteBit ( NX / NOP? ) was the problem.
So I setup a Win2K machine / Celeron ( Northwood-128 ) and installed the Retail CD version on it.
Installed SP4 and Post-SP4 Rollup 1. No NX / NOP? bit support in OS or hardware.
OLE errors killed the game ( COM+ memory errors. )
WINE on Linux also reports lots of OLE errors.

Additional Questions :

Does version 1.36 require WinXP for the correct version of COM+ ?
Is this a memory limitation error? Is a 16 bit memory manager used in AoW.exe?

Any suggestions are welcome. I am at wits end.

[EDIT:] Update ...

Tried install path ( c:\aow1 ) and compatibility set to Win98.
Same error.

Looked at the map size. Seems anything with over 80 cities will generate this error.

Conclusion :
Its a 16 bit memory limitation, or poor quality program code. State updates not being applied ( variables updated incorrectly / not updated / set to NULL / unintentionally overwritten ).

Considering that the spell "Earth Mastery" never has applied the "Stone Skin" effect to all of the player units ...
Considering that the spell "Fire Mastery" never removes the applied large fires effects from the map when dispelled...

Its a coding / memory problem. Either the original source code needs to be debugged, or a replacement engine is necessary to fix this error.

[This message has been edited by turtleplayer (edited 10-26-2015 @ 10:18 AM).]

Replies:
posted 10-28-15 03:27 PM EDT (US)     1 / 2  
Hmm, I think I have the same config as you: Win7 x64 with latest AOW patch.

Does this only happen on one map? Does it only happen while playing, or only with cut scenes?

I will get errors occasionally with custom-made maps downloaded from this website. Most of the time I can do some combination of alt-tab or alt-Windows to bring up the error window, close, and continue playing without quitting the game.
posted 05-14-17 10:04 PM EDT (US)     2 / 2  
If you're hitting this error message, check this out:

https://github.com/int19h/aow-patch/blob/master/README.md
Age of Wonders 2 Heaven » Forums » AoW1 Technical Help » Win7 Pro x64 and MapViewer.ShowScene errors.
Top
You must be logged in to post messages.
Please login or register
Hop to:    
Age of Wonders 2 Heaven | HeavenGames