You must be logged in to post messages.
Please login or register

AoW2 Gameplay Help & Strategies
Moderated by ChowGuy, Swolte, Ziggurat Mason

Hop to:    
loginhomeregisterhelprules
Bottom
Topic Subject: bug on official campaign - undead mission 2
posted 07-20-11 12:37 PM EDT (US)   
Hello guys. I must report a bug that don't let me finish the stage in the official campaign.
I'm now in the second mission of death mana source. There is an alliance with Meandor, and i must defeat an alliance with Nekron, storm and serena.
I've killed Nekron first (the game shows his defeat).
I've killed Tempest (the game shows his defeat).
Then the only one i miss, i Serena. When i defeat her, the game don't show her defeat as she can resurrect in an another elf city. But the only problem is that THERE ARE NO MORE elf cities!
I've tried also to break the alliance with Meandor, i kill him and conquered all his resource and territory BEFORE kill Serena. IT doesn't change anything. I've tried to check if i miss any elf cities, but it's all maded by undead and shadow elf cities. What can i do?
below the links with the images of surface and underground of the stage.
Who can help me? How did u complete the scenario?
Surface

underground

[This message has been edited by masterjimmy (edited 07-20-2011 @ 12:39 PM).]

Replies:
posted 07-20-11 12:58 PM EDT (US)     1 / 8  
I haven't played the campaign in years and years so someone else probably has a much better idea about the problem.

Have you considered that the city might be hidden in a forest? Since the Elven racial building cloaks the city in trees. True sight would help you find it.

Just an idea.
posted 07-20-11 03:06 PM EDT (US)     2 / 8  
i can try... but i'm pretty sure that in this situation is not possibile. There is no place in which they can have another city...
i also give her 5000 and 10000 of mana. She's not doing anything

[This message has been edited by masterjimmy (edited 07-20-2011 @ 03:09 PM).]

posted 07-20-11 10:02 PM EDT (US)     3 / 8  
I have not yet ever finished the campaign for the Wizard's Throne...but I have been reading from the official strategy guide to help answer your question.

The Official Strategy Guide states that Serena starts with two initial wizard's towers! (So there must still be one that is cloaked like Euandor has already surmised).

(Spoiler)...Here are some tips I gleaned from reading the guide...

Use the teleporter across the bridge to the southeast of Fallz to travel to an underground area in the northwest almost directly beneath her capitol city. (This would be a good way to raid her territory).

Keep your mobile Death Knights and Executioners patrolling your backlands along the north/south road while you build up your infrastructure.

Summon Bone Dragons and build up to level 3 and level 4 units as soon as possible.

The cave entrance down the road to the west from Norvaz (Neckron's former capitol) drops down into a long underground corridor that runs south to one exit, then angles up to the northwest to a second exit. This second exit emerges near both of Serena's initial Wizard Tower cities.


Cheers and good luck!
posted 07-21-11 05:23 AM EDT (US)     4 / 8  
i can try to check the invisible cities.... but i'm not so hopefull. I give her so much money that she can now create any kind of units and explore the entire world. She hasn't produced anything....
posted 07-21-11 02:38 PM EDT (US)     5 / 8  
My advice is to cheat, however terrible that sounds



There is the list of cheats. I would recommend "explore", "fog" and "towns".

And if your scenario is really bugged, you can always type in "win" and finish the scenario.

[This message has been edited by Euandor (edited 07-21-2011 @ 02:39 PM).]

posted 11-02-11 04:47 AM EDT (US)     6 / 8  
No cheats needed. The last town of Serena is in the underground in the upper right corner.
You get there with the beamer/teleporter at the surface in the upper left corner. Notice: The last town is well guarded with angels!!
Hope it helps anyone; i read a walkthrough with the hope to find the last town, but in this silly walkthrough they wrote, that the teleporter is in the underground garden?!?
I then tried every teleporter and the above one was the clue...
posted 11-07-11 03:31 PM EDT (US)     7 / 8  
Unfortunately the undead mission 3 is bugged ;( It is only possible to travel to the undeads last fortress with the first unit which enters the first underground place. There you will be attacked by three units and then you get to the labyrinth. But you can't use the secret transporter a second time ;((
posted 11-07-11 08:38 PM EDT (US)     8 / 8  
She has a teleporter on the surface on the western edge of the map - IIRC, to the west or southwest of her main cluster of cities, and close to the exit from her underground city that you can get to from the teleporter in the south of Nekron's territory (which has a sign nearby along the lines of "The Underground Garden").

EDIT: Decided to go into my savefile and check - the teleporter is pretty much due west of Heartwood, and south of the exit from the Underground Garden.

The exit of the teleporter is surrounded by Holy Woods and has a sign somewhere labelling it as a shelter. To the east of the teleporter exit is her wizard tower-equipped city.

You don't need to worry about hidden cities - that option isn't available until Shadow Magic.

Good luck!

[This message has been edited by Draxynnic (edited 11-08-2011 @ 03:16 AM).]

Age of Wonders 2 Heaven » Forums » AoW2 Gameplay Help & Strategies » bug on official campaign - undead mission 2
Top
You must be logged in to post messages.
Please login or register
Hop to:    
Age of Wonders 2 Heaven | HeavenGames